Open Bug 1708882 Opened 7 months ago Updated 4 months ago

(Proton) (regression) back/forward an reload icons are no longer correctly aligned in toolbar

Categories

(Firefox :: Theme, defect, P2)

defect
Points:
1

Tracking

()

REOPENED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- fixed

People

(Reporter: soeren.hentzschel, Assigned: jaws, NeedInfo)

References

Details

(Keywords: regression, Whiteboard: [proton-icons] [priority:2a])

Attachments

(3 files)

Attached image screenshot.png

The back/forward an reload icons are no longer correctly aligned in toolbar. This is a noticeable visual regression in the primary UI. I attached a (zoomed) screenshot that shows both Firefox 89 Beta (top) and Firefox 88 (bottom).

See Also: → 1705428
Priority: -- → P2
Whiteboard: [proton-icons] → [proton-icons] [priority:2a]
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/260f7bc5d6f6
Center the reload/stop button vertically with respect to the other toolbarbutton icons. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

This is not fixed (macOS).

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached image screenshot

:jaws, please see the attached screenshot. While I am not sure if the position of the icon can be furthed improved (maybe a pixel rounding thing?) it's very noticeable that the background of the icon has a different position on hover.

Flags: needinfo?(jaws)

I think we should back this out. I'm on PTO this week. Harry, what do you think?

Flags: needinfo?(jaws) → needinfo?(htwyford)

If we back this out, the icons will be always be misaligned like in comment 0. IMO, that's worse than the button hover backgrounds being misaligned. I'm in favour of not backing this out. The hover state should definitely be fixed, but that will require changing the reload animation. It's possible that won't get done for 90. If I had to pick one, I'd rather 90 ship with misaligned hover backgrounds rather than the icons always being misaligned.

Seeing as Jared and I disagree here, I think we should get another opinion to break the tie. Dao, thoughts?

Flags: needinfo?(htwyford) → needinfo?(dao+bmo)

(In reply to Harry Twyford [:harry] from comment #8)

The hover state should definitely be fixed, but that will require changing the reload animation. It's possible that won't get done for 90. If I had to pick one, I'd rather 90 ship with misaligned hover backgrounds rather than the icons always being misaligned.

I'm happy to fix this but I don't yet see where the problem is being introduced. The hover state simply colors the background of image.toolbarbutton-icon, so a misalignment on hover is just revealing a misalignment of the image or a parentNode in all states. It does appear to be a pixel too low, but all the paddings and margins match up.

Points: --- → 1

Since a patch for this bug landed in Firefox 90, I think this bug should be closed so the status is tracked correctly.

The issue in comment 5 may have been fixed by bug 1710328. If there are still issues, I think new bugs should be created.

Flags: needinfo?(soeren.hentzschel)
You need to log in before you can comment on or make changes to this bug.