Closed Bug 1710338 Opened 3 years ago Closed 10 months ago

Firefox Account email shown as first hamburger menu item

Categories

(Firefox :: Firefox Accounts, enhancement, P2)

Firefox 88
enhancement

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox116 --- fixed

People

(Reporter: paralel.nonrecurently, Assigned: markh)

References

Details

(Keywords: blocked-ux)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0

Steps to reproduce:

Open the hamburger menu while logged in to Firefox Account, see that first item is the email of the current account.

Actual results:

As the first item is the email of the current account, this makes it really easy for someone over my shoulder to look at the email I used to make the account. Even lending my computer to someone for a moment would make it possible for them to know my email without even trying.

Expected results:

First item should show the name the user has chosen for the account and something like "Firefox Account" if no name was chosen.

The Bugbug bot thinks this bug should belong to the 'Cloud Services::Server: Firefox Accounts' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Server: Firefox Accounts
Product: Firefox → Cloud Services

I agree with the reporter - we have something explicitly called "Display name" - if the user sets it, it's what they want displayed. @gijs, I can't recall who was responsible for this redesign - can you please needinfo them?

Component: Server: Firefox Accounts → Firefox Accounts
Flags: needinfo?(gijskruitbosch+bugs)
Product: Cloud Services → Firefox

(In reply to Mark Hammond [:markh] [:mhammond] from comment #2)

I agree with the reporter - we have something explicitly called "Display name" - if the user sets it, it's what they want displayed. @gijs, I can't recall who was responsible for this redesign - can you please needinfo them?

I'm kind of confused - comment 0 is, per the UA string, filed from Firefox 86, which doesn't have any of the MR1 redesign work. Did we not show the display name pre-MR1?

I'm also confused because it suggests not using the email address when no account name was set, which seems like it would be less personal, and if the user has multiple accounts, they would not know which one was signed in. Treating an e-mail address as private information for shoulder surfing is kind of odd - would we not display it anywhere?

In terms of the UX folks involved with MR1's app menu, I'd suggest checking in the #proton channel on slack. I don't know off-hand who did the design work here. The implementation was mconley and emalysz, I think.

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(markh)

(In reply to :Gijs (he/him) from comment #3)

I'm kind of confused - comment 0 is, per the UA string, filed from Firefox 86, which doesn't have any of the MR1 redesign work. Did we not show the display name pre-MR1?

The UA string is a mistake on my part, I was testing something and forgot to change it back. I filed this from 88.0.1 as it was also present in the previous design.

Maybe my solution/intent was too specific, but I still think showing the account name in place of the account email makes more sense than just showing the email even if a name was chosen.

(In reply to :Gijs (he/him) from comment #3)

I'm kind of confused - comment 0 is, per the UA string, filed from Firefox 86, which doesn't have any of the MR1 redesign work. Did we not show the display name pre-MR1?

You're correct as usual. There's no regression here. There are some stylistic changes that makes the email more prominent, and I jumped to the conclusion it was a recent change. I'll keep my needinfo to push this to a conclusion :)

I will mark this issue as New. The corresponding team will continue with its analysis.

Status: UNCONFIRMED → NEW
Ever confirmed: true

It's difficult to work out exactly how we ended up here, but things changed quite a lot in bug 1562006 - but even there, the email address of the account was prominent in the top-level hamburger menu, with the display name shown only in the account sub-menu. That's now gone from the sub-menu, but even if it hadn't this issue would remain.

I'll try and find someone from product or UX to weigh in here.

Flags: needinfo?(markh)
Keywords: blocked-ux

Bug 1810631 is the same report but for Fenix. Vesta, do you have any thoughts?

Flags: needinfo?(vzare)
See Also: → 1810631

We don't currently ask the user to provide a display name during registration so I can assume that only a small % of users have one - those who went into account settings and chose a display name - and it would be interesting to see what that % is. Regardless, I agree that seeing the Display name in the menu (instead of email address) is a fair expectation for such users who intentionally chose a display name. I will take this recommendation back to UX.

Flags: needinfo?(vzare)

Landed in Fenix via bug 1810631, we should do this on desktop too!

Priority: -- → P2
Duplicate of this bug: 1837433

Now Fenix does this and iOS always did, Desktop is now the outlier - so I'm putting up a patch to prefer the display name over the email address.

Assignee: nobody → markh
Status: NEW → ASSIGNED
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac865e33c777
Prefer the FxA displayName over the email address in the app menu. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: