Table containing degree symbol (0x00B0) + other stuff has infinite height

RESOLVED DUPLICATE of bug 113779

Status

RESOLVED DUPLICATE of bug 113779
17 years ago
14 years ago

People

(Reporter: kevin, Assigned: asa)

Tracking

({qawanted, testcase})

Trunk
x86
Windows 2000
qawanted, testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

10-day forecast table displays mostly a tall blank area. This bug appeared w/o
changing version of Mozilla, 2 weeks ago (or so) when it seems weather.com
changed its output for this URL. The bug appears in Mozilla 1.0, 1.1, and 1.2a.
For reference, IE6 displays OK.

Reproducible: Always

Steps to Reproduce:
1. Load the URL
2.
3.

Actual Results:  
Bug, as described

Expected Results:  
Depends on whether there is bad HTML being produced by weather.com or not.
IE6 displays the page normally.

Comment 1

17 years ago
worksforme with linux trunk build 20020925

Comment 2

17 years ago
WFM Windows XP build 20020926
(Reporter)

Comment 3

16 years ago
From original Reporter:
Re-installed mozilla, problem persisted. Rebooted Win2K, problem dissappeared.
Probably should mark this one down as not (easily) reproducible.

Comment 4

16 years ago
I also encounter this problem on Windows 2000, under Mozilla 1.2b (build
2002101612).  Rebooting does not seem to fix for me.

Comment 5

16 years ago
WFM with 2002122708/trunk/win2k.

reporter (Kevin): can you reproduce this bug with a recent build of mozilla (for
example, 1.3a)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.

Comment 6

16 years ago
I can duplicate this in 2003011604 under Win2k.  (saw it on a build from a few
days ago also).  It's actually much, much worse at
http://www.solarbuzz.com/Customer.htm

Comment 7

16 years ago
Eric: could you describe exactly what's wrong with
http://www.solarbuzz.com/Customer.htm

it looks ok to me with linux trunk 20030116

Comment 8

16 years ago
Well, it was similar to weather.com's problem-- staggeringly tall blank spaces
(so much so that the scrollbar was essentially unusable).  But I went ahead and
rebooted my 2K box (hate doing that for various reasons, so held off until I
needed to do so anyway) and the problem went away. 

Trying to think of what might be cleared by a reboot that wouldn't be cleared by
a shutdown and restart...  I did make sure that the Moz executable was gone
after I closed it.  Hmmm.... 

Comment 9

16 years ago
Confirming bug with 2002121215 (1.3alpha) on Windows XP.  Also occurs with a
nightly I downloaded earlier today, but uninstalled because of other problems.

Will attach screenshot of problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
Created attachment 113169 [details]
screenshot of 10-day forecast problem

Comment 11

16 years ago
WORKSFORME Win2k 20030219

Comment 12

16 years ago
I can see this bug Win 2000, using Mozilla 1.3a

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Comment 13

16 years ago
those of you who can reproduce the problem, can you produce a testcase
for this? Also, what is your graphic card? And does upgrading graphic
driver help?
Keywords: qawanted

Comment 14

16 years ago
Created attachment 123732 [details]
HTML fragment of table with blank area

This fragment reproduces the bug.   It still reproduces for me with Mozilla
1.4b on Win2000, using an nVidia TNT2 video adapter.

Comment 15

16 years ago
the attachment seems to display fine for me (linux trunk 20030517)

> table with blank area

what is blank?  does the whole table not show up?

Comment 16

16 years ago
Steve, can you reproduce the bug after removing every degree sign?

Comment 17

16 years ago
Created attachment 123790 [details]
Absolute minimum testcase

This one-row table is the absolute minimum testcase.  With the degree symbol
present, Mozilla computes the row height as 'infinite'.  With the degree symbol
removed, the row height is computed normally.

Comment 18

16 years ago
It wasn't necessary to remove ALL the degree symbols from the 5/19 testcase to
get it to draw correctly.  Only the one instance in the "header" had to be changed.

The new 5/20/2003 attachment is the absolute minimum test case - leave the
degree symbol in, and Mozilla computes the row height as essentially "infinite".
 Take it out, and all is well.

(In the Weather.com original content, Mozilla does eventually 'give up' on that
row and render the rest of the page - but you have to press the "End" key to
jump to the end of the page to see it.)

Comment 19

16 years ago
Update:  removing any one of the following things in the 'absolute minimum
testcase' causes the row height to be calculated properly.

1.  The <b> ... </b> surrounding the information in the <td> element

2.  The 'align="center"' attribute on the <td> element

3.  The degree symbol (Unicode 0x00B0) in the <td> element's content

If all three of these things are present (bold, center aligned, degree symbol)
then the calculation goes wrong.  

Comment 20

16 years ago
Created attachment 123811 [details]
Absolute minimum testcase
Attachment #123790 - Attachment is obsolete: true

Updated

16 years ago
Keywords: testcase
Summary: 10-day forecast table displays mostly a tall blank area. → Table containing degree symbol (0x00B0) + other stuff has infinite height

Comment 21

16 years ago
*** Bug 203562 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
this is probably a dupe of bug 113779.
Steve, Kevin or Bill: can you reproduce this bug with a recent trunk or 1.4
branch build?  bug 113779 has been fixed for a while on both.  1.5a should have
the fix.

Comment 23

16 years ago
Just tested it using
http://ftp.mozilla.org/pub/mozilla/nightly/2003-08-15-09-trunk/mozilla-win32-svg-GDI-mathml.zip,
and the problem no longer occurs on either my test cases or the live
www.weather.com site.

Comment 24

16 years ago
> the problem no longer occurs on either my test cases

good enough for me.

marking dupe of "The site displays badly (lots of blank space) and scroll bar
acts strangely (?)"

*** This bug has been marked as a duplicate of 113779 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.