Closed Bug 1711902 Opened 1 year ago Closed 1 year ago

Use mozilla::intl::DateTimeFormat in SpiderMonkey

Categories

(Core :: Internationalization, task, P2)

task

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: gregtatum, Assigned: gregtatum)

References

Details

(Whiteboard: [i18n-unification])

Attachments

(5 files)

Bug 1705156 creates an initial unified interface for the DateTimeFormat, and this bug is for tracking using that interface inside of SpiderMonkey'sjs/src/builtin/intl/DateTimeFormat.cpp.

This patch starts the work of unifying the DateTimeFormat. It removes the uses
of UDateFormat.

Attachment #9223042 - Attachment description: WIP: Bug 1711902 - part1: Remove UDateFormat from SpiderMonkey; r?dminor,tcampbell → Bug 1711902 - Remove UDateFormat from SpiderMonkey; r?dminor,tcampbell,anba
Attachment #9223044 - Attachment description: WIP: Bug 1711902 - part2: Unify the DateTimePatternGenerator in SpiderMonkey; r?tcampbell,dminor → Bug 1711902 - Unify the DateTimePatternGenerator in SpiderMonkey; r?dminor,tcampbell,anba

This adds a bigger unification primitive of an Enumeration iterator over the
UEnumeration ICU type.

Depends on D115731

This finishes the UCalendar unification in DateTimeFormat.cpp

Depends on D116157

Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a17c65a3d5d
Add a FormatBuffer for use in SpiderMonkey; r=anba
https://hg.mozilla.org/integration/autoland/rev/a357df76d933
Remove UDateFormat from SpiderMonkey; r=dminor,anba
https://hg.mozilla.org/integration/autoland/rev/e724d9c81340
Unify the DateTimePatternGenerator in SpiderMonkey; r=dminor,anba
https://hg.mozilla.org/integration/autoland/rev/7473f72977c7
Unify most of UCalendar in SpiderMonkey; r=dminor,anba
https://hg.mozilla.org/integration/autoland/rev/b770983d1375
Add Calendar::GetCanonicalTimeZoneID; r=dminor
Duplicate of this bug: 1709473
Blocks: 1719672
Whiteboard: [i18n-unification]
You need to log in before you can comment on or make changes to this bug.