Mousing over label does not highlight related form input element

RESOLVED DUPLICATE of bug 12518

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED DUPLICATE of bug 12518
15 years ago
12 years ago

People

(Reporter: Tim Powell, Unassigned)

Tracking

Trunk
Future
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
To better match the Windows XP platform behavior, hovering over a label tag
should cause the related form input element to highlight, just as if you moused
over the form element itself. This is the behavior of checkboxes and radio
buttons in native dialogs. IE6 shows the hover effect for the HTML form element
when you hover over the text label.

To Reproduce:
Go to an HTML form that uses label tags to associate text with a control.
Mouse over a control that shows a hover effect, such as a checkbox or radio
button. (Note that the hover effect occurs when over the actual element.)
Mouse over the label for the control.

Actual:
The cursor turns to an arrow to show the text is clickable, but the hover effect
doesn't occur.

Expected:
The cursor should turn into an arrow and the associated form widget should show
its hover effect.

This change would make HTML forms behave more like the native platform.

Interestingly, the preferences dialog in Phoenix behaves as expected when you
hover over text labels. Observed in Phoenix nightly 2002-09-26-18-trunk.

Comment 1

15 years ago
Isn't this related to (or a dupe) bug 12518? Although I guess this bug is
specific to Windows XP using the native platform theme, and emulating the
theme's behaviour with form labels, whereas 12518 seems to be any windows
version, so perhaps this should block that?

The test case attached in bug 12518 comment 1 (attachment 1392 [details]) seems like a
good example of this bug's behaviour.

Comment 2

15 years ago
Good idea, but won't be easy to do right.
Priority: -- → P3
Target Milestone: --- → Future

Comment 3

15 years ago
-> default owner
Assignee: jkeiser → form

Comment 4

15 years ago
I may as well say what I was thinking ... the correct way to do this, it seems
to me, is to make :hover occur on the corresponding control when it is turned on
on the label.

Comment 5

14 years ago
*** Bug 253611 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.0?

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 6

12 years ago
*** Bug 315902 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Also, could this bug ALSO be a duplicate, of bug 12518?

Whether it is or not, you should take a look at the test HTML document in this bug: https://bugzilla.mozilla.org/attachment.cgi?id=145551

Note also, like I mentioned in my (duplicate) bug above, when a radio button / check box or its label is clicked on or gets the focus, you get an ugly dotted border around it (Windows XP).  Now the dotted border is to indicate focus, I know.  But if there is a label, it should go around that instead.

*** This bug has been marked as a duplicate of 12518 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.