Closed Bug 1712663 Opened 1 year ago Closed 9 months ago

Firefox Dev Edition will resize the vertical height of tabs on websites which dynamically change the text in the tab (tab referring to the literal clickable tab at the top; not the actual page).

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1714276

People

(Reporter: mattwilson888, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Go to a website which dynamically changes the text inside the clickable tab (top bar tab selector). TradingView charts are good examples, sometimes happens on Twitter.

Actual results:

The vertical height of the entire tab bar will increase, then decrease, randomly. This shifts the whole web page below it even if that tab is not being viewed. Incredibly annoying.

Expected results:

Tab height should remain a constant.

The Bugbug bot thinks this bug should belong to the 'Firefox::Tabbed Browser' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Tabbed Browser

Likely a duplicate of bug 1704404, if they're adding special characters.

I have attempted reproducing this issue along with its possibly duplicate one, but I was unsuccessful. I have attempted reproducing in Ubuntu 20 with i3, Ubuntu 20 with Sway, Fedora 33 with Wayland on all the latest versions of the main channels. I also attempted changing the system font as discussed in the other bug, but I was still unsuccessful.

Matt, will you please provide us with the exact steps to reproduce?
Which Linux distribution are you using? Which exact Firefox version are you using?
Can you provide us with a website that reproduces this issue on your system?
(Does it happen with this one: testpage?)

Thank you!

Flags: needinfo?(mattwilson888)
See Also: → 1716661
See Also: → 1704404

mattwilson888, does your issue persist?
it should not be fixed in the latest Firefox (Release).

I don't know for sure whether this issue still happens, but at least https://bugzilla.mozilla.org/show_bug.cgi?id=1714276 (which is related as it's also about ugly resizing of tabs) still happens with the latest nightly release: "93.0a1 (2021-08-26) (64-bit)" on xubuntu-18.04.5.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
See Also: 1716661, 1704404
Duplicate of bug: 1714276
Flags: needinfo?(mattwilson888)
You need to log in before you can comment on or make changes to this bug.