Open Bug 1713625 Opened 3 years ago Updated 1 month ago

offline support for CALDAV-calendar not working correctly - synchronization works one-way


(Calendar :: Provider: CalDAV, defect)

Thunderbird 91
Windows 10


(Not tracked)


(Reporter: ma15d57, Unassigned)



User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

When I create a new calendar-entry (CALDAV) inside thunderbird on my desktop-computer, everthing is fine. Thunderbird synchronizes all server-entries when a network-connection is established to the CALDAV-server (e.g. Nextcloud).

When I do the same on my Notebook with enabled "offline-support" for this calendar, thunderbird synchronizes also all server-entries from the CALDAV-server.

But after a few time the synchronization doesn't work... we get no error-report,.. but not all (new) calender-entries from the CALDAV-server are shown.
The only (really not good) solution is:
1.) verify that the network-connection to the CALDAV-server is established
2.) disable the "offline-support" for this calendar
3.) start manual synchronization
4.) enable the "offline-support" for this calendar

Unfortunately, I cannot ensure that I always have a network connection (for the notebook), so permanently deactivating offline support (as with my desktop pc) is not a solution.

Actual results:

After a few time the offline-synchronization of CALDAV-calendars doesn't work... without any error-report,...
Not all (new) calender-entries from the CALDAV-server are shown.

Expected results:

The start of a (manual) complete synchronization should also do exactly just that.

PS: Many users in several inzternet-forums describes exactly this wrong behavior...


we've found another (quick-and-very-dirty) hack for solve this problem temporarily:
1.) close 'thunderbird'
2.) wait for the process to finish
3.) delete the complete calendar-cache-folder;
e.g. 'C:\Users\<username>\AppData\Roaming\Thunderbird\Profiles\<profilename>.default\calendar-data'
4.) open/start 'thunderbird'

Hopefully, someone can found another (good) solution :-)

Thunderbird 91.2.1 (64 bit), Calendar (implemented), Windows 10 Pro, CALDAV via Synology DS418 calendar app (all up to date)

Hi all,

I can support the existence of the reported problem with offline-calendar data synchronised via CALDAV.

In short what I did:

Offline-support OFF

  1. Entry of new event (1h), via mouse, data by double click +12h alarm --> appears okay in Synology DS calendar app
  2. Changing the event to 2h length (mouse) --> again okay in DS
  3. Changing the start by dragging --> again okay in DS
  4. Dragging the event in DS to other time --> okay in TB after manual sync (didn't want to wait for half an hour)
    5a. Attempt to change length of event by mouse-action to 30 min in TB fails (minimum length accepted is 1h15min) NEW ERROR --> change is followed on DS side (duration 1:15h)
    5b. Double clicking and changing to 30 minutes works in TB --> okay in DS as well
  5. Again, event set to 2 hours duration in TB --> again okay in DS
  6. Changing via mouse in DS to 30 min duration --> appears correct in TB after manual sync

Offline-support ON
8. No change of event, manual sync: event remains but alarm disappears in TB --> remains as it was in DS (length, alarm)
9. Again change of duration to 2 h in TB --> duration change appears in DS, but alarm disappears here as well !!!
10. Attempt to create new event in TB via mouse --> nothing visible in TB, no warning, but empty event in DS calendar (syncronizing doesn't help)
11. Attempt creating event via right click, data entry, setting alarm in TB --> nothing visible in TB, no warning, but correct appearance in DS

Offline-support OFF
12. After manual sync both events being created in 10. and 11. are now visible but no alarm in TB --> unchanged in DS,as described in 8. above

My conclusion at the moment:
The function is usable in-house, but risky (even impractical) when using it offline e.g. on a notebook.

Tested on a Notebook with Linux-Mint 20.2
Tested with a portable TB on a USB-Stick under Windows 10

Okay, after fiddling another day it seems that I've solved almost all issues by creating new profile data. It looks like something was broken (still no idea where).

Actually, a remaining issue is a misleading "calendar not available" and "Modification failed" error message popping up when changing or adding anything in a calender file while being offline. Additionally a warning sign appears, decorating the respective calendar. Even if the message itself is correct as far as the CALDAV-server is concerned the explanation (leading towards snoozing or dismissing failures) is irritating in this context.
However, after confirming the warning everything seems to work.
Proposal: Avoiding a pop-up warning when offline-support is selected. Just add silently a message or icon offline instead of the warning icon.

A second issue is the remaining warning icon after being connected again to the CALDAV-server, even if everything seemed to be synchronised. It disappears only after adding a new entry or after rebooting TB. In most cases there might had been be a restart before while I've tested the offline mode by interrupting and re-connecting the WLAN-connection.

Sorry... nothing is solved :-(

Same problem in TB 91.3.2 and still no solution and no reaction :-(((

OS: Unspecified → Windows 10
Priority: -- → P1
Hardware: Unspecified → x86_64
Version: Thunderbird 78 → Thunderbird 91
Priority: P1 → --

Huge problems here as well. Several CalDAV-calendars with thousands of entries and 12 parallel connections (staff members working with calendars on their computers) not syncing properly with Offline-Support enabled.
Cannot use Thunderbird's calendar any more, because it is not reliable!
Thunderbird 91.5.1 (64bit), Windows 10 (64bit)

Same here. Seems to be related to this offline-support option. The connection of CalDAV calendars (Nextcloud) seems to get disturbed at one moment and then changes don't get synced anymore. Same with calendar alerts. It's not possible to close or snooze them. No error appears (no message/no error icon).
In this case a restart of TB helps. But this situation is very limiting.
Same: Thunderbird 91.5.1 (64bit), Windows 10 (64bit)

I can confirm this bug in my machine:
Thunderbird 91.6.1 (64 bit)
OS: Linux Mint 20.3 Cinnamon (64 bit)

With offline mode enabled for the calendar the synchronization works one-way. Events created in Thunderbird are synchronized to SOGO and then to all my other devices. But in the reverse direction it stops working after a while. Manual sync doesn't work as long as offline mode is enabled.

Without offline mode everything works fine.

I can confirm this issue too with TB 102.5.0 (64 bits) on OpenSuse Leap 15.4 and nextcloud 24 as Caldav provider. The workaround is either to disable offline mode or to remove and recreate the caldav resource. Simple TB restart is not enough.

I also can confirm this behaviour with TB 12.6.1 (64bit) on Windows 10 64bit and nextcloud 25.0.3. My workaround is to disable offline support, delete content of all tables of calendar entries in ...\calendar-data\cache.sqlite and reenable offline support. But the misbehaviour may soon reoccur.

Duplicate of this bug: 1799938

Confirming based on multiple reports.

Ever confirmed: true
Summary: offline support for CALDAV-calendar not working correctly → offline support for CALDAV-calendar not working correctly - synchronization works one-way

Confirmed on TB 102.10 under ubuntu, synced with Nextcloud 26.0.1
Very annoying bug, with no visible error messages.

Confirmed on TB 102.15 with Nextcloud CALDAV Server. C Level considers going back to Google Office because important calendar entries are not always synced to the thunderbird lightning calendar devices of the invited users.

What is the purpose of the offline mode for a calender in detail? How is it supposed to work properly? What is stopping it to do so?

Severity: -- → S2

(In reply to phaidros from comment #13)

Confirmed on TB 102.15 with Nextcloud CALDAV Server. C Level considers going back to Google Office because important calendar entries are not always synced to the thunderbird lightning calendar devices of the invited users.

It seems there was probably another overlaying bug introduced on Nextcloud lately:

As first it seems the original bug report ist way older than the probably cause of the onementioned above (, that there is still something in the bushes here.

I have no understanding so far, how the calendar offline-mode might fail to update in cases of shared calendars or longer refresh periods (a user being offline for lets say a month, and the event never gets synced after), as there could be server-client race conditions or others.

Could anyone be so kind to point to the actual code where the calendar offline-mode does its magic?

Confirmed on TB 115.3.1 with Xandikos v0.2.8 - not NextCloud - as CalDAV server.
This is not a NextCloud bug, this is a Thunderbird bug.

See Also: → 1853632

For me this issue happens with Thunderbird 102.15.1 as well as TB 115.3.1
The used CalDAV server is SOGo 5.9.0

This happens most often and obviously when events are deleted on a shared calendar.
Client1 deletes an event. This gets synched correctly to the CalDAV server.
But on Client2 this change does not get synched from the CalDAV server to client2. On client2 the deleted event still is shown in the calendar.

Workaround on client2 is to disable "offline support" for the affected calendar and then enable it again.

I confirm this behaviour since TB 91; it is still present with TB 115.3.1 (with Zimbra server).

My opinion is that this bug is extremely serious because:

  • it is quite erratic: sometimes it does not happen for days, and sometimes I have to restart TB several times a day because I notice that a calendar does not update anymore
  • it is silent : there is no error message nor any sign that something is going wrong with calendar updates
  • the most important is that the crucial objective of an agenda is to remember events. I've already missed some important appointments due to this bug so now I prefer to trust my phone more, but it's not satisfactory.

I imagine the cause of the problem may be difficult to find. Perhaps a quick workaround would be to offer users to perform a complete update (clear and repopulate the cache) every x hours, as it is done in some Android clients like CalDAV-sync?

See Also: → 1857871
See Also: → 1858088

Another confirmation: Ubuntu 23.04 + TB 115.3.1 and another machine with Ubuntu 23.10 with TB 115.3.1. Both machines connected to three Nextcloud accounts (all on Nextcloud server version 27.1.2).

Looks like this is related to/a duplicate of bug 1694709.

See Also: → 1694709
You need to log in before you can comment on or make changes to this bug.