Closed Bug 1714821 Opened 5 months ago Closed 2 months ago

[Windows 10] Can't delete bookmark separators in menus

Categories

(Firefox :: Bookmarks & History, defect, P3)

Firefox 89
Desktop
Windows 10
defect
Points:
2

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- wontfix
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- fixed

People

(Reporter: rielname, Assigned: bigiri)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [proton-cleanups])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36 OPR/73.0.3856.284 (Edition Yx 03)

Steps to reproduce:

Created a bookmark separator in the newest version of Firefox (89.0 64-bit)

Actual results:

I tried to delete it but it would not delete

Expected results:

It should have deleted!

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

I can reproduce the issue on Windows10.
It is almost impossible to delete.
The hit point area against the separator seems too narrow.

See screencast https://youtu.be/ChxcjJUpydw. It took more than a dozen right clicks near the separator to bring up the context menu for Delete menu.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

(In reply to Alice0775 White from comment #2)

I can reproduce the issue on Windows10.
It is almost impossible to delete.
The hit point area against the separator seems too narrow.

See screencast https://youtu.be/ChxcjJUpydw. It took more than a dozen right clicks near the separator to bring up the context menu for Delete menu.

You are a lifesaber

(In reply to Alice0775 White from comment #2)

I can reproduce the issue on Windows10.
It is almost impossible to delete.
The hit point area against the separator seems too narrow.

See screencast https://youtu.be/ChxcjJUpydw. It took more than a dozen right clicks near the separator to bring up the context menu for Delete menu.

Why did you mark this as blocking proton? Is this a proton regression? (That would kind of surprise me.)

Flags: needinfo?(alice0775)

non-proton(Firefox87): the menuseparator is 5px in height

menuseparator {
    appearance: auto;
    -moz-default-appearance: menuseparator;
    padding: 3px 1px 4px;
    border-top: 1px solid ThreeDShadow;
    border-bottom: 1px solid ThreeDHighlight;
}

proton(Nightly91): the menuseparator is only 1px in height

menuseparator {
    appearance: none;
    border-top: 1px solid var(--menu-border-color);
    border-bottom: none;
    padding: 0;
    margin: 2px 1em;
}

So, I blocked the proton context.

Flags: needinfo?(alice0775)

OK, thanks for clarifying. I was mostly confused because the toolbar separators haven't been touched, and from comment #0 it was not clear to me this was about the ones in menus.

Blocks: proton-cleanups
No longer blocks: proton-context-menus
Severity: -- → S3
Points: --- → 2
Depends on: 1703051
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Summary: Can't delete bookmark separator → [Windows 10] Can't delete bookmark separators in menus
Whiteboard: [proton-cleanups]
Priority: -- → P3
Assignee: nobody → bigiri
Status: NEW → ASSIGNED

Proton removed the default HR appearance and replaced padding with margins. Unfortunately margins are not clickable. So this patch replaces margins with padding while maintaining the look of proton on Windows, MacOS, and Linux. Doing this required a few CSS tricks.

Pushed by bigiri@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db9c60da7473
Make bookmark separators easier to delete r=mak,desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Flags: qe-verify+

Given the dependencies involved, I'm not sure we should try backporting this to ESR91. If you want to provide a rebased patch, however, we can consider it.

You need to log in before you can comment on or make changes to this bug.