Closed Bug 1715155 Opened 6 months ago Closed 6 months ago

Perma [tier 2] TEST-UNEXPECTED-PASS | /css/css-properties-values-api/at-property.html | Inherited properties inherit - expected FAIL

Categories

(Core :: CSS Parsing and Computation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- unaffected
firefox91 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=342046752&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/MvvL5nXaQSSHOqMfLNgDmQ/runs/0/artifacts/public/logs/live_backing.log


[task 2021-06-07T23:13:05.128Z] 23:13:05     INFO - TEST-OK | /css/css-properties-values-api/at-property-typedom.html | took 431ms
[task 2021-06-07T23:13:05.129Z] 23:13:05     INFO - TEST-START | /css/css-properties-values-api/at-property.html
[task 2021-06-07T23:13:05.156Z] 23:13:05     INFO - Closing window 807ddbdf-1905-4404-bd73-7274e0e149f9
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - 
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - TEST-FAIL | /css/css-properties-values-api/at-property.html | Rule applied [<color>, tomato, true] - assert_equals: expected "rgb(255, 99, 71)" but got ""
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - test_applied/<@http://web-platform.test:8000/css/css-properties-values-api/at-property.html:91:18
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:37
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - with_style_node@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:101:7
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:18
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - test_with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:30
[task 2021-06-07T23:13:05.603Z] 23:13:05     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - test_with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:7
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - test_applied@http://web-platform.test:8000/css/css-properties-values-api/at-property.html:85:24
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:131:13
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule applied for "*", even with no initial value 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [undefined, green, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [<color>, undefined, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [<color>, green, undefined] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [<gandalf>, grey, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [gandalf, grey, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [<color>, notacolor, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-PASS | /css/css-properties-values-api/at-property.html | Rule not applied [<length>, 10em, false] 
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - TEST-FAIL | /css/css-properties-values-api/at-property.html | Non-inherited properties do not inherit - assert_equals: expected "0px" but got "40px"
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:161:18
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:37
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - with_style_node@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:101:7
[task 2021-06-07T23:13:05.604Z] 23:13:05     INFO - with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:18
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - test_with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:30
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - test_with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:7
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:153:22
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - TEST-UNEXPECTED-PASS | /css/css-properties-values-api/at-property.html | Inherited properties inherit - expected FAIL
[task 2021-06-07T23:13:05.605Z] 23:13:05     INFO - TEST-INFO | expected FAIL
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - 
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - TEST-FAIL | /css/css-properties-values-api/at-property.html | Initial values substituted as computed value - assert_equals: expected "rgb(0, 128, 0)" but got ""
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:190:18
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:37
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - with_style_node@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:101:7
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:18
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - test_with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:30
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - test_with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:7
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:183:22
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - TEST-UNEXPECTED-FAIL | /css/css-properties-values-api/at-property.html | Non-universal registration are invalid without an initial value - assert_equals: expected " calc(1px + 1px)" but got "calc(1px + 1px)"
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:203:18
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:37
[task 2021-06-07T23:13:05.607Z] 23:13:05     INFO - with_style_node@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:101:7
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:117:18
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - test_with_at_property/<@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:30
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - test_with_at_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:121:7
[task 2021-06-07T23:13:05.608Z] 23:13:05     INFO - @http://web-platform.test:8000/css/css-properties-values-api/at-property.html:196:22
[task 2021-06-07T23:13:05.686Z] 23:13:05     INFO - TEST-OK | /css/css-properties-values-api/at-property.html | took 556ms
[task 2021-06-07T23:13:06.023Z] 23:13:06     INFO - STDOUT: cleanup aborted: Unable to remount device
[task 2021-06-07T23:13:06.132Z] 23:13:06     INFO - STDOUT: cleanup aborted: Unable to remount device
[task 2021-06-07T23:13:06.133Z] 23:13:06     INFO - Closing logging queue
[task 2021-06-07T23:13:06.134Z] 23:13:06     INFO - queue closed
[task 2021-06-07T23:13:06.156Z] 23:13:06     INFO - Setting up ssl
[task 2021-06-07T23:13:06.177Z] 23:13:06     INFO - certutil | b''
[task 2021-06-07T23:13:06.193Z] 23:13:06     INFO - certutil | b''
[task 2021-06-07T23:13:06.206Z] 23:13:06     INFO - certutil | b'\nCertificate Nickname                                         Trust Attributes\n                                                             SSL,S/MIME,JAR/XPI\n\nweb-platform-tests                                           CT,, \n'
[task 2021-06-07T23:13:07.082Z] 23:13:07     INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2021-06-07T23:13:08.404Z] 23:13:08     INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env0 MOZ_CRASHREPORTER=1 --es env1 MOZ_CRASHREPORTER_NO_REPORT=1 --es env2 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env4 MOZ_IN_AUTOMATION=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env6 R_LOG_LEVEL=6 --es env7 R_LOG_DESTINATION=stderr --es env8 R_LOG_VERBOSE=1 --es env9 MOZ_PROCESS_LOG=/tmp/tmpu5be_315pidlog --es env10 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env11 STYLO_THREADS=1 --es env12 MOZ_WEBRENDER=0 --es arg0 -no-remote --es arg1 -profile --es arg2 /data/local/tmp/test_root/profile --es arg3 --marionette --es arg4 about:blank --ez use_multiprocess True
[task 2021-06-07T23:13:09.299Z] 23:13:09     INFO - Starting runner
[task 2021-06-07T23:13:09.876Z] 23:13:09     INFO - TEST-START | /css/css-properties-values-api/conditional-rules.html
<...>
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - TEST-FAIL | /css/css-properties-values-api/registered-property-computation.html | <resolution> values are computed correctly [calc(1dppx + 96dpi)] - CSS.registerProperty is not a function
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - generate_property@http://web-platform.test:8000/css/css-properties-values-api/resources/utils.js:67:7
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - with_custom_property@http://web-platform.test:8000/css/css-properties-values-api/registered-property-computation.html:27:33
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - assert_computed_value@http://web-platform.test:8000/css/css-properties-values-api/registered-property-computation.html:43:25
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - test_computed_value/<@http://web-platform.test:8000/css/css-properties-values-api/registered-property-computation.html:70:30
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:14.726Z] 23:13:14     INFO - test_computed_value@http://web-platform.test:8000/css/css-properties-values-api/registered-property-computation.html:69:9
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - @http://web-platform.test:8000/css/css-properties-values-api/registered-property-computation.html:168:20
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - TEST-UNEXPECTED-FAIL | /css/css-properties-values-api/registered-property-cssom.html | CSSOM setters function as expected for unregistered properties - assert_equals: expected " 10px" but got "10px"
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - @http://web-platform.test:8000/css/css-properties-values-api/registered-property-cssom.html:28:16
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2087:25
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - test@http://web-platform.test:8000/resources/testharness.js:557:30
[task 2021-06-07T23:13:14.727Z] 23:13:14     INFO - @http://web-platform.test:8000/css/css-properties-values-api/registered-property-cssom.html:26:5
[task 2021-06-07T23:13:14.833Z] 23:13:14     INFO - TEST-OK | /css/css-properties-values-api/registered-property-cssom.html | took 415ms
[task 2021-06-07T23:13:15.188Z] 23:13:15     INFO - STDOUT: cleanup aborted: Unable to remount device
[task 2021-06-07T23:13:15.313Z] 23:13:15     INFO - STDOUT: cleanup aborted: Unable to remount device
[task 2021-06-07T23:13:15.315Z] 23:13:15     INFO - Closing logging queue
[task 2021-06-07T23:13:15.315Z] 23:13:15     INFO - queue closed
[task 2021-06-07T23:13:15.338Z] 23:13:15     INFO - Setting up ssl
[task 2021-06-07T23:13:15.359Z] 23:13:15     INFO - certutil | b''
[task 2021-06-07T23:13:15.380Z] 23:13:15     INFO - certutil | b''
[task 2021-06-07T23:13:15.401Z] 23:13:15     INFO - certutil | b'\nCertificate Nickname                                         Trust Attributes\n                                                             SSL,S/MIME,JAR/XPI\n\nweb-platform-tests                                           CT,, \n'
[task 2021-06-07T23:13:16.320Z] 23:13:16     INFO - adb Granting important runtime permissions to org.mozilla.geckoview.test
[task 2021-06-07T23:13:17.629Z] 23:13:17     INFO - adb launch_application: am start -W -n org.mozilla.geckoview.test/org.mozilla.geckoview.test.TestRunnerActivity -a android.intent.action.MAIN --es env0 MOZ_CRASHREPORTER=1 --es env1 MOZ_CRASHREPORTER_NO_REPORT=1 --es env2 MOZ_CRASHREPORTER_SHUTDOWN=1 --es env3 MOZ_HIDE_RESULTS_TABLE=1 --es env4 MOZ_IN_AUTOMATION=1 --es env5 MOZ_LOG=signaling:3,mtransport:4,DataChannel:4,jsep:4 --es env6 R_LOG_LEVEL=6 --es env7 R_LOG_DESTINATION=stderr --es env8 R_LOG_VERBOSE=1 --es env9 MOZ_PROCESS_LOG=/tmp/tmpjmmejxoipidlog --es env10 MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 --es env11 STYLO_THREADS=1 --es env12 MOZ_WEBRENDER=0 --es arg0 -no-remote --es arg1 -profile --es arg2 /data/local/tmp/test_root/profile --es arg3 --marionette --es arg4 about:blank --ez use_multiprocess True
[task 2021-06-07T23:13:18.471Z] 23:13:18     INFO - Starting runner
[task 2021-06-07T23:13:19.046Z] 23:13:19     INFO - TEST-START | /css/css-properties-values-api/registered-property-initial.html

Emilio,
Could this be caused by the changes in Bug 1713787?

Flags: needinfo?(emilio)

Yup

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c7a3b3284798
Fix some @property subtest to account for whitespace trimming, and update expectations for another subtest that's now passing. r=xidorn
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29281 for changes under testing/web-platform/tests
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.