Closed Bug 1716546 Opened 1 year ago Closed 1 year ago

Some "Bookmarks Menu" submenus have gaps on corner borders

Categories

(Core :: Widget: Gtk, defect)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: joshas, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Testing Firefox Nightly 91.0a1 (2021-06-14) (64-bit) on Fedora 34 (GNOME, Wayland).
Add "Bookmarks Menu" button to toolbar. Open "Bookmarks Menu" and hover on any folder to open a submenu.

Actual results:

Submenu border has noticable gaps in corners. It seems that content inside submenu might be leaking outside and covering borders with its white background.

Expected results:

Submenu should use the same style as main Bookmarks Menu, including shadow.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Can you use mozregression [1] to find the broken commit?
Thanks.
[1] https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Use_Mozregression_tool

Blocks: wayland
Flags: needinfo?(joshas)

Here are the results from mozregression:

8:14.03 INFO: Narrowed integration regression window from [d5eadbb2, ccd42a3a] (3 builds) to [6ad04d52, ccd42a3a] (2 builds) (~1 steps left)
8:14.03 INFO: No more integration revisions, bisection finished.
8:14.03 INFO: Last good revision: 6ad04d52247403e0fe1d00fc2ed540354a8e8eb8
8:14.03 INFO: First bad revision: ccd42a3adbe3b3444613038b5a846336fb9ca690
8:14.03 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6ad04d52247403e0fe1d00fc2ed540354a8e8eb8&tochange=ccd42a3adbe3b3444613038b5a846336fb9ca690
Flags: needinfo?(joshas)

I can repro, thanks.

Assignee: nobody → emilio
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(emilio)
Attachment #9227695 - Attachment description: Bug 1716546 - Fix bookmarks submenu styling on Linux. r=dao,#desktop-theme-reviewers → Bug 1716546 - Fix and cleanup bookmarks submenu styling. r=dao,#desktop-theme-reviewers
Flags: needinfo?(emilio)
Duplicate of this bug: 1717225
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a74fee26e242
Fix and cleanup bookmarks submenu styling. r=desktop-theme-reviewers,harry
Pushed by imoraru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60e1992cce13
fix linting failure. r=fix CLOSED TREE
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Flags: qe-verify+
Regressions: 1720880

I have reproduced this issue using Firefox 91.0a1 on Ubuntu 18.04 x64.
I can confirm this issue is fixed, I verified using Firefox 96.0 on Ubuntu 18.04 x64, Windows 10 x64 and macOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.