Mozilla Firebird forgets icon size and forces small toolbar buttons

VERIFIED WORKSFORME

Status

()

Firefox
Toolbars and Customization
VERIFIED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Tim Powell, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
After upgrading to the 2002-09-29-15 phoenix nightly on Win2K, the toolbars had
switched to small icons. I clicked customize (awesome dialog!) and saw the "Use
small icons" checkbox was unchecked. I toggled it on and off again and got large
icons back. However, this choice is forgotten if I shut down and restart Phoenix.

Comment 1

15 years ago
Furthermore, even when large icons are restored, new windows
(for instance File -> New Window) still use small icons.

Reassigning to hewitt since he made the last changes on CTB.
Assignee: hyatt → hewitt

Comment 2

15 years ago
If you open a new window after going from small to large the new window doesn't
get large icons and when you restart you'll have small icons again. 

Workaround, customize, get the size you want and immediately restart. That
worked for me. 

Comment 3

15 years ago
I have a somewhat different situation here: In Ph0.1, I defined to use small
icons, without text. Now with the 20020930 build, I wanted to add the buttons
"History" and "Download manager" and it used the big icons. Switching to big
icons, and switching back to small icons did the trick.

Comment 4

15 years ago
*** Bug 172148 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 172493 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 172517

Comment 6

15 years ago
Related bug: select 'small icons',select text only icons, and then select
icon-only. Phoenix then shows large icons (forgetting the original 'small'
setting. Probably when in text-only the 'small' attribute is removed.
However, this behavious in annoying, as just switching to/from text-only should
not change iconsize.

Comment 7

15 years ago
Alfred:
patches in bug 172517 eliminate the problem you mentioned

Comment 8

15 years ago
The problem noted in comment 1 and comment 2 is fixed by the patch in bug 173444.

Updated

15 years ago
Summary: Phoenix forgets icon size and forces small toolbar buttons → Mozilla Firebird forgets icon size and forces small toolbar buttons

Comment 9

15 years ago
Perhaps you could try and push for your patches to get checked in on those bugs
djk and then we can close all three?
Taking QA Contact
QA Contact: asa → bugzilla

Comment 11

15 years ago
Colin,

As you can see, I created all my FB patches a while ago, and have only updated a
few since then (they probably bitrotted...)  The lack of activity for a few
months on FB killed my motovation and I have moved on (not that I blame anyone;
I know how hard it is to find free time).

In fact, _I_ don't have the time to work on any of the patches ATM, so someone
will have to clean them up and get them checked in.

Once I get some free time, I'll look at those which haven't yet been checked in,
especially now since development is picking up again. woohoo!  :-)

Regards,
David

Comment 12

15 years ago
This bug (comments 0-3) WFM. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.5b) Gecko/20030728 Mozilla Firebird/0.6.1

Anyone else? Can we close this?

Comment 13

15 years ago
I haven't seen this particular bug in quite a while, either.

Any issues mentioned in comment 1, comment 2, and comment 6 seem to be addressed
by other bugs.

I'd say WFM, too.

Comment 14

15 years ago
was on 7-24. Not on 7-29
I don't see this either anymore. 
-> WORKSFORMR
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.