Closed Bug 1717781 Opened 1 year ago Closed 1 year ago

Linux tsan crashtest tasks often lost, task resolved with 'CLAIM_EXPIRED'

Categories

(Core :: Sanitizers, defect)

defect

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- unaffected
firefox91 --- fixed

People

(Reporter: aryx, Assigned: jonco)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

During the last week, the Linux tsan crashtest task has failed 12 times (= 6 attempts on the same push, higher failure rate if one looks at the attempts) because the worker stopped communicating with taskcluster (e.g. it crashed) - first failure.

Jon, could this be from bug 1715562?

Flags: needinfo?(jcoppeard)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #0)
It could be. Is it still happening since bug 1716940 landed?

Flags: needinfo?(jcoppeard) → needinfo?(aryx.bugmail)

The issue still affects the latest pushes and backfills indicate it started with bug 1716940.

Flags: needinfo?(aryx.bugmail)
Regressed by: 1716940
Has Regression Range: --- → yes

I can run these tests locally without issue (modulo some TSAN warnings) but they do take a lot of memory (~10GB for the first chunk). I don't think this is directly related to my push (note the previous push also has some failures).

Increasing the chunking fixes the problem on try.

Assignee: nobody → jcoppeard

This fixes test crashes suspected to be caused by memory exhaustion.

Blocks: tsan
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0edf427fa9f
Increase the number of chunks for linux64 tsan builds r=aryx
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
You need to log in before you can comment on or make changes to this bug.