drag & drop an .eml file into a mailbox folder

RESOLVED FIXED in Thunderbird 3.0b3

Status

enhancement
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: robert.pollak, Assigned: philbaseless-firefox)

Tracking

(Blocks 2 bugs)

Trunk
Thunderbird 3.0b3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Once I saved an email as eml-file and deleted it from my mail folders, I cannot
get it into a mail folder again.
This could be useful e.g. to create a reply, or to "edit message as new".

Workaround: drag & drop it to Outlook Express, then Tools->Import... from there.

I am using 1.1 on Windows 2000. Does this work on Linux?
(Reporter)

Updated

17 years ago
Blocks: 155643

Updated

17 years ago
Severity: normal → enhancement
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 11076 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
The request in this bug is to drag n drop the eml into the local folder listing.
 The bug this is currently marked a dup of requests that a clicking on an eml
brings up a Compose window or loads the message in a stand alone mail window. 
Reporter, please confirm that your intent in this bug is to dnd the eml to the
folder listing and then please add that to the summary and we'll go from there.

Updated

17 years ago
QA Contact: olgam → esther
(Reporter)

Comment 3

17 years ago
Confirming, Esther. This bug has nothing to do with opening the mail for
reading. It's about adding it to a mailbox folder. I changed the summary to be
more clear. Should I reopen this bug?
Summary: import eml file by drag & drop → drag & drop an eml file into a mailbox folder
(Reporter)

Comment 4

17 years ago
Reopening. It seems to be a mistake that this bug was marked dup of bug 11076.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Whiteboard: DUPEME

Updated

16 years ago
Depends on: 193281
Product: Browser → Seamonkey
hange 'eml' in summary to '.eml' for ease of search ('extremly' will hit).
Summary: drag & drop an eml file into a mailbox folder → drag & drop an .eml file into a mailbox folder
Blocks: 269826
No longer depends on: 269826

Updated

14 years ago
Assignee: sspitzer → mail
Status: REOPENED → NEW
OS: Windows 2000 → All
Hardware: PC → All
Assignee: mail → nobody
QA Contact: esther → message-display
(Assignee)

Comment 6

10 years ago
this would be nice.
All windows live mail is textfile    *.eml format and could be imported with ease if we had open or drag and drop
(Assignee)

Updated

10 years ago
Assignee: nobody → philbaseless-firefox
(Assignee)

Updated

10 years ago
Depends on: 498978
(Assignee)

Updated

10 years ago
Depends on: 499304
(Assignee)

Updated

10 years ago
Attachment #384330 - Flags: review?(mkmelin+mozilla)
Comment on attachment 384330 [details] [diff] [review]
[checked in] adds drag and drop of external .eml file

Seriously awesome work, Phil!

>+        if (extFile.isFile()){

Missing space

>+          let len = extFile.leafName.length;
>+          if (len > 4 && extFile.leafName.substr(len-4).toLowerCase() == '.eml') {
>+            cs.CopyFileMessage(extFile, targetFolder, null, false, 1, "", null, msgWindow);
>+          }

Don't need the braces, and prefer " instead of single quotes when you don't need to (for consisency)

I've fixed that and checked this in for you.
changeset:   2920:a488e6167960
http://hg.mozilla.org/comm-central/rev/a488e6167960

I'll leave it for you to move this to the Thunderbird component and mark it fixed (+ clone this bug for seamonkey), or make a seamonkey fix.
Attachment #384330 - Flags: review?(mkmelin+mozilla) → review+
Attachment #384330 - Attachment description: adds drag and drop of external .eml file → [checked in] adds drag and drop of external .eml file
I did notice for some messages the imap server complained about "bare newlines in message"... but that's for another bug. Most messages worked fine.
(Assignee)

Comment 10

10 years ago
Magnus, thanks for review, can you post the email IMAP didn't like. I have some bugs which this depends on. Although, I don't that is correct since logically they only become real bugs when this is checked in. But they might be related to your IMAP error.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago10 years ago
Component: MailNews: Message Display → Mail Window Front End
Product: SeaMonkey → Thunderbird
QA Contact: message-display → front-end
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Blocks: 499878
Filed bug 500479 about those.
(Assignee)

Updated

10 years ago
Blocks: 500564
Checked with next build. 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090625 Shredder/3.0b3pre

(1) Drag&Drop of .eml to local mail folder => mail is imported => OK
(2) Crafted "From " line in mail body is escaped by ">From " => OK

(3) Drag& Drop of real .eml file(First line is not "From ").    
(3-1) Required envelope line of "From - ..." is not written in Unix Mbox
      style file Tb uses => added mail is lost by Rebuild-Index.
(3-2) X-Mozilla:/X-Mozilla-2:/X-Mozilla-Keys: headers is not created.
      It's same as current import, but it's better to be cared for.

Should we open separate bug for (3)?

(4) Drag& Drop of Tb's Unix Mbox file(one mail only) which is renamed to ".eml".
    (1-st line is "From - ...", X-Mozilla-Status: etc. exist)
    New "From - ..." line is not added. (Problem of (3))
    All data is copied to folder file, including first "From - ..." line,
    and X-Mozilla-Status:, X-Mozilla-Keys: etc. are processed.
    => If "X-Mozilla-Status: 0009", data is copied to flder file, but is
       imported as deleted mail, then mail is not displayed at thread pane.
    => If "X-Mozilla-Keys: $label1 ..." exists, tag is added.

(4) is very convinient for testing, because we now can add various mail data while Tb is running by Drag&Drop only, without any additional manual operation such as add tag, mark as Unread, without slightly dangerous "replacing mail folder file content and changing file size, followed by manual rebuild-index".
However, "Tb's X-...: headers in .eml file" is usually produced by spam mail or malware. I think they are better to be ignored/removed and replaced by new Tb's ones which currently will be added by "Compact Folder".
Phil Lacy, what do you think? Should we open separate bug for it?
(Assignee)

Comment 13

10 years ago
(In reply to comment #12)
> Should we open separate bug for (3)?

Bug 499304

> malware. I think they are better to be ignored/removed and replaced by new 

I can't answer to that. But it was my intent that saved eml messages should be as is with existing headers.  But I can't say that is correct. Maybe additional tags should be added to indicate preexisting headers exist form original .eml.
(Assignee)

Comment 14

10 years ago
(In reply to comment #12)
> (2) Crafted "From " line in mail body is escaped by ">From " => OK

this isn't consistent with imported code which escapes "From " with preexisting prefixes of 0 or more '>'
the escapefromline code is in nsMsgUtils.cpp.  Maybe that should be used in CopyData() but either way it would be another bug.
Target Milestone: --- → Thunderbird 3.0b3
You need to log in before you can comment on or make changes to this bug.