Closed Bug 1719124 Opened 4 months ago Closed 2 months ago

For larger PDF files "WebDriver:Print" can raise "RangeError: too many arguments provided for a function call"

Categories

(Testing :: Marionette, defect, P3)

Firefox 81
defect

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: whimboo, Assigned: jacek, Mentored, NeedInfo)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [lang=js], [wptsync upstream])

Attachments

(1 file, 1 obsolete file)

Originally reported as: https://github.com/mozilla/geckodriver/issues/1905

It's actually similar to the issue that we had with our CDP implementation, and which got fixed by bug 1632722. The same approach we need for Marionette here:

https://searchfox.org/mozilla-central/rev/b7bc94b4689a7f002c61d016c6e162e5e5708bf3/remote/marionette/driver.js#3023-3027

The issue is around since Firefox 73 when the print feature has been implemented by bug 1604506.

Mentor: hskupin
Whiteboard: [lang=js]
Assignee: nobody → jacek
Status: NEW → ASSIGNED
Attachment #9233964 - Attachment description: WIP: Bug 1719124 Split PDF data into chunks to avoid hitting function call argument limit → Bug 1719124 Split PDF data into chunks to avoid hitting function call argument limit

Depends on D121363

Attachment #9234003 - Attachment is obsolete: true
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4079bc8d46ca
Split PDF data into chunks to avoid hitting function call argument limit r=webdriver-reviewers,jgraham,whimboo
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29929 for changes under testing/web-platform/tests
Whiteboard: [lang=js] → [lang=js], [wptsync upstream]

Backed out changeset 4079bc8d46ca (Bug 1719124) for causing failures on printcmd.py.
Backout link
Push with failures
Failure Log

Flags: needinfo?(jacek)
Upstream PR was closed without merging
Attachment #9233964 - Attachment description: Bug 1719124 Split PDF data into chunks to avoid hitting function call argument limit → Bug 1719124 - [marionette] Split processing PDF data into chunks to avoid hitting function call argument limit
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c036c370ef15
[marionette] Split processing PDF data into chunks to avoid hitting function call argument limit r=webdriver-reviewers,jgraham,whimboo
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.