Closed Bug 1719546 Opened 1 year ago Closed 1 year ago

Unify Intl APIs in layout/base/nsBidi.h

Categories

(Core :: Internationalization, task, P3)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: gregtatum, Assigned: gregtatum)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [i18n-unification], [i18n-unification-help-wanted])

Attachments

(3 files)

Work: Medium
What it is: Moving the nsBidi abstraction into the unified components, and updating it to match our practices.

Blocks: 1719664

This seems like a larger project that Greg or I should take on. Greg will flesh out some more details on this project.

Blocks: 1719543
Flags: needinfo?(gtatum)

Looking into this, it appears we can mostly copy and paste nsBidi into the intl/src/components and then update the naming and conventions to match the unified intl components. It would be nice to also move the all the definitions into the .cpp file, then we wouldn't have to expose the ICU internals in the header. It appears the constructor is infallible, so it won't need the TryCreate method.

Some new tests will need to be written for it. I don't see anything at this unit level.

I'm updating this as open for contributions beyond Dan or I, since it's adapting an existing abstraction.

Flags: needinfo?(gtatum)
Whiteboard: [i18n-unification-help-wanted]
Whiteboard: [i18n-unification-help-wanted] → [i18n-unification], [i18n-unification-help-wanted]
Assignee: nobody → gtatum
Blocks: 1736595
Blocks: 1736597
Attachment #9246522 - Attachment description: Bug 1719546 - Remove nsBidi; r?#platform-i18n-reviewers!' → Bug 1719546 - Remove nsBidi; r?#platform-i18n-reviewers!
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e69fc596f2c3
Create a unified bidi component; r=platform-i18n-reviewers,dminor
https://hg.mozilla.org/integration/autoland/rev/a1f7ed6c4251
Replace nsBidi with mozilla::intl::Bidi; r=platform-i18n-reviewers,dminor
https://hg.mozilla.org/integration/autoland/rev/c4d6ffc7e445
Remove nsBidi; r=platform-i18n-reviewers,dminor
Flags: needinfo?(gtatum)
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2877faf8d2fa
Create a unified bidi component; r=platform-i18n-reviewers,dminor
https://hg.mozilla.org/integration/autoland/rev/20965e0af9b3
Replace nsBidi with mozilla::intl::Bidi; r=platform-i18n-reviewers,dminor
https://hg.mozilla.org/integration/autoland/rev/0f203e8e17f9
Remove nsBidi; r=platform-i18n-reviewers,dminor
Regressions: 1737028
You need to log in before you can comment on or make changes to this bug.