Closed Bug 1720003 Opened 2 months ago Closed 20 days ago

Allow browser focus to be avoided

Categories

(SeaMonkey :: Tabbed Browser, enhancement)

enhancement

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.90
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.10)

Attachments

(1 file, 3 obsolete files)

Add the ability to avoid focusing the browser window when opening a new tab in it.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: no extra non-focusing abilities
Testing completed (on m-c, etc.): 2.53.9
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none

Attachment #9230606 - Flags: review?(frgrahl)
Attachment #9230606 - Flags: approval-comm-release?
Attachment #9230606 - Flags: approval-comm-esr60?
Blocks: 1713458

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: less abilities
Testing completed (on m-c, etc.): 2.53.9
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: 2 new strings plus associated help changes

Help might still need further work - should background tab loading be mentioned?

This requires version 1.3 of patch on Bug 1713458

Other patch on here requires version 1.4

Attachment #9230611 - Flags: review?(frgrahl)
Attachment #9230611 - Flags: approval-comm-release?
Attachment #9230611 - Flags: approval-comm-esr60?

Changes since last version:

  • Don't ignore avoidBrowserFocus when tab is loading in the background
Attachment #9230611 - Attachment is obsolete: true
Attachment #9230611 - Flags: review?(frgrahl)
Attachment #9230611 - Flags: approval-comm-release?
Attachment #9230611 - Flags: approval-comm-esr60?
Attachment #9230640 - Flags: review?(frgrahl)
Attachment #9230640 - Flags: approval-comm-release?
Attachment #9230640 - Flags: approval-comm-esr60?

Changes since last version:

  • Also expose browser.tabs.loadDivertedInBackground pref
Attachment #9230640 - Attachment is obsolete: true
Attachment #9230640 - Flags: review?(frgrahl)
Attachment #9230640 - Flags: approval-comm-release?
Attachment #9230640 - Flags: approval-comm-esr60?
Attachment #9230801 - Flags: review?(frgrahl)
Attachment #9230801 - Flags: approval-comm-release?
Attachment #9230801 - Flags: approval-comm-esr60?
Attachment #9230606 - Attachment is obsolete: true
Attachment #9230606 - Flags: review?(frgrahl)
Attachment #9230606 - Flags: approval-comm-release?
Attachment #9230606 - Flags: approval-comm-esr60?

Comment on attachment 9230801 [details] [diff] [review]
1720003-avoidbrowserfocus-v1_3-2539.patch

LGTM

Attachment #9230801 - Flags: review?(frgrahl)
Attachment #9230801 - Flags: review+
Attachment #9230801 - Flags: approval-comm-release?
Attachment #9230801 - Flags: approval-comm-release+
Attachment #9230801 - Flags: approval-comm-esr60?
Attachment #9230801 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/9c3ada89441d
Allow browser focus to be avoided. r=frg

Status: ASSIGNED → RESOLVED
Closed: 20 days ago
Resolution: --- → FIXED
Whiteboard: SM2.53.10
Target Milestone: --- → seamonkey 2.90
You need to log in before you can comment on or make changes to this bug.