Closed Bug 1720693 Opened 3 months ago Closed 1 month ago

Multiple Primary Password prompts result in an unreachable prompt and an unresponsive window

Categories

(Core :: Widget: Cocoa, defect, P2)

Desktop
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mconley, Unassigned)

References

Details

(Keywords: regressionwindow-wanted)

Attachments

(1 file)

I've started to notice this recently in Nightly (most recently experienced it in Firefox Nightly 92.0a1 build ID 20210714093409).

I have a Primary Password set. Sometimes, when I'm away from Firefox for a while, I'll come back, and it will appear to have prompted for the Primary Password more than once. One of the prompts is in the foreground, and I can fill it out, but then another will seem to exist just above and behind my main (and only) browser window. This is unreachable, I can't fill it out, and my browser window is unresponsive while it waits for me to fill out this unreachable unfillable password dialog.

I'm not sure that's enough information to go on, but I thought I'd at least get this filed. I've experienced this once a day for a few days now.

Component: Notifications and Alerts → Widget: Cocoa
Product: Toolkit → Core
Severity: -- → S2
Priority: -- → P2
QA Whiteboard: [qa-regression-triage]

This happened to me twice today, and I have a new piece of information: both times, I had just unlocked the screen to find that Firefox was requesting the Primary Password. So it's possible that the double-request of the Primary Password needs to occur during screen lock in order for this bug to be reproduced.

Duplicate of this bug: 1720975

Hey Mike, do you happen to have Sync enabled on the affected profile?

Flags: needinfo?(mconley)

I do, yes.

Flags: needinfo?(mconley)

FWIW, Refresh Firefox seems to have cleared up this issue for me. Two days and counting.

FF 90.0.2, macOS 11.5.1
Sync: enabled.
Extensions: Disable HTML5 Autoplay, Duck Duck Go Privacy Essentials, Facebook Container, OneTab.

I had been using extension HTTPS Everywhere but deemed it no longer necessary and disabled.
I did need to save and re-import saved OneTab content to avoid losing it.

After running four days running, FF re-prompted for the master password (different bug # I think). The prompt was front and center, though--not grayed out/hidden cf. this bug.

I haven't seen this bug in a few days. I've definitely come back to my machine, woken it up out of sleep, seen the primary password dialog, and filled in the password - but each time, it's done the right thing and not shown me a second one detached and unreachable.

So I'm tempted to close this as WORKSFORME unless anybody else is still seeing this. I'll wait a few days for somebody to mention they're still seeing the bug before doing that.

I just saw this again. Another factor that might have contributed is that I believe I had a GCal background tab that was showing a modal alert at the time.

Hey Mike, we have a fix that might solve this issue as well and it just landed on the latest Nightly, see Bug 1721084. After updating to the latest Nightly please let us know if you encounter this again or not in the upcoming days/weeks.

Flags: needinfo?(mconley)

Hi tbabos,

I have not seen this bug recur in the past few weeks, so I'm going to close this as WORKSFORME. I'll re-open if I happen to see it again. Thanks!

Status: NEW → RESOLVED
Closed: 1 month ago
Flags: needinfo?(mconley)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.