Closed Bug 1721306 Opened 10 months ago Closed 9 months ago

[Fission BFCache] Hover text does not disappear when navigating to a different page

Categories

(Core :: DOM: Navigation, defect, P2)

Firefox 92
defect

Tracking

()

RESOLVED FIXED
92 Branch
Fission Milestone M8
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox90 --- unaffected
firefox91 --- disabled
firefox92 --- fixed

People

(Reporter: 1justinpeter, Assigned: smaug)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, reproducible, Whiteboard: fission-hard-blocker)

Attachments

(3 files)

Attached file about:support

Honestly no idea what component to put this in, sorry.

When hovering over an <img> with the title attribute set, a popup with this text will appear. Normally this text disappears when the mouse is no longer hovering over the image, but this does not happen if the page is navigated away from.

Steps to reproduce:

  1. Navigate to m.xkcd.com (or another page with an image and title text)
  2. Hover over the image
  3. Press ctrl+L and navigate to a different page (Note: for the STR to work, the address bar suggestions must not cover the mouse; using a taller image or pasting an address may help here).
  4. The hover text does not go away

Things that make the text go away:

  • Switching tabs

Things that do not make the text go away:

  • Reloading the tab
  • Moving the mouse outside of the window
  • Minimizing the window

Occurs on the latest nightly, please ask if you have any questions or there's anything I can do to help.

I can reproduce the issue if Fission is enabled.

Blocks: fission
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible
Summary: Hover text does not disappear when navigating to a different page → [Fission ] Hover text does not disappear when navigating to a different page
Has Regression Range: --- → yes
Has STR: --- → yes
Component: General → DOM: Navigation
Keywords: regression
Regressed by: 1715300
Fission Milestone: --- → ?
Summary: [Fission ] Hover text does not disappear when navigating to a different page → [Fission] Hover text does not disappear when navigating to a different page

Alice, thanks for finding the regression range!

DOM Navigation code is responsible for hiding the tooltip. LocationChange events are being sent to the old content process.

Tracking for Fission MVP.

Severity: -- → S3
Fission Milestone: ? → M8
Priority: -- → P2
Summary: [Fission] Hover text does not disappear when navigating to a different page → [Fission BFCache] Hover text does not disappear when navigating to a different page

This bug is a hard blocker for Fission M8.

Whiteboard: fission-hard-blocker

Olli, I'm tentatively assigning this Fission M8 bug to you because it appears to be a regression from bfcacheInParent.

Assignee: nobody → bugs
Flags: needinfo?(bugs)

FWIW, this is an old issue. One can trigger this even without Fission by killing a child process when the tooltip is shown.
Obviously Fission with bfcache makes this happen more easily.

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37008f131c6f
hide the tooltip when deactivating a BrowserParent, r=peterv

Backed out changeset 37008f131c6f (Bug 1721306) for causing bustages on SessionHistoryEntry.cpp.
Backout link
Push with failures
Failure Log

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cb9f52db17e
hide the tooltip when deactivating a BrowserParent, r=peterv
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Flags: needinfo?(bugs)

I can confirm that this is now fixed.

You need to log in before you can comment on or make changes to this bug.