Closed Bug 1721454 Opened 2 months ago Closed 2 months ago

Second "Manage bookmarks" item is not at bottom of Bookmarks Menu after landing patch from bug #1720534

Categories

(Firefox :: Bookmarks & History, defect)

Firefox 92
Desktop
All
defect

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- verified

People

(Reporter: Virtual, Assigned: mconley)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

First and second "Manage bookmarks" items in Bookmarks Menu are separated only by 2 items, which are "Bookmarks toolbar" and "Other bookmarks".

The regression is caused by:

Bug 1720534 - Clean up styles in Bookmarks Menu Button menupopups on Windows 7 and 10. r=desktop-theme-reviewers,dao

This also gets rid of a dead CSS class (panel-subview-footer).

Differential Revision: https://phabricator.services.mozilla.com/D119906

Flags: needinfo?(mconley)
Duplicate of this bug: 1723754

This issue also affects Mac and although I haven't checked, mostly likely linux as well. Although the regressing issue component is themes, I'm moving to Bookmarks and History, since IMO, it belongs there.

Component: Theme → Bookmarks & History
OS: Windows 7 → All
Hardware: x86_64 → Desktop
Assignee: nobody → mconley
Flags: needinfo?(mconley)

The CSS class panel-subview-footer-button was removed from the BMB_bookmarksShowAll
element in the Bookmarks Menu toolbar button, but this class is used by browser-places.js
to know where to insert the user's bookmarks in the structure of the menu.

Since this is the only menu that attachPlacesView attaches to, we can supply
the ID of the bottom Manage Bookmarks element, which will cause browserPlacesView.js
to insert the user's bookmarks above it.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ccf38b42b39b
Insert bookmarks before bottom Manage Bookmarks in Bookmarks Menu button. r=NeilDeakin
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.