Closed Bug 172175 Opened 19 years ago Closed 19 years ago

Mozilla hangs on paradise lost - handling Flash

Categories

(Core :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 172172

People

(Reporter: paul.carr, Assigned: peterl-bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910

After the splash page at the subject URL, Mozilla hangs and does not respond to
either mouse or keyboard.  Hsd to force quit.

Reproducible: Always

Steps to Reproduce:
1. get the Flash plugin if not presently installed.
2. Go to http://www.paradiselosttheopera.com/home.html
3.

Actual Results:  
Browser hangs when Flash file loads.

Expected Results:  
Normal operations

my plugin: Shockwave Flash 6.0 r29


Frameset source:

 
<html>
<head>
<title>Paradise Lost</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<!--
Popup Window
Version 2.0
-->
<SCRIPT LANGUAGE="JavaScript"> var javascript_version = 1.0;</SCRIPT>
<SCRIPT LANGUAGE="JavaScript1.1">  javascript_version = 1.1;</SCRIPT>
<SCRIPT LANGUAGE="JavaScript">

var newwin;

function launchwin(winurl,winname,winfeatures)
{
	//This launches a new window and then
	//focuses it if window.focus() is supported.
	newwin = window.open(winurl,winname,winfeatures);
	if(javascript_version > 1.0)
	{
		//delay a bit here because IE4 encounters errors
		//when trying to focus a recently opened window
 		setTimeout('newwin.focus();',250);
	}
}
</SCRIPT>
</head>
<frameset cols="*,750,*" rows="*" border="0" framespacing="0" frameborder="NO"> 
  <frame src="left_frame.html" name="leftframe" noresize scrolling="NO"
marginwidth="0" marginheight="0" frameborder="NO">
  <frameset rows="25,*" cols="*" border="0" framespacing="0" frameborder="NO"> 
    <frame src="header.html" name="header" noresize scrolling="NO"
frameborder="NO" marginwidth="0" marginheight="0">
    <frameset rows="422,*"> 
      <frame src="mid_content.html" name="content" scrolling="NO"
marginwidth="0" marginheight="0" frameborder="NO" noresize>
      <frame src="footer_intro.html" marginwidth="0" marginheight="0"
scrolling="NO" noresize frameborder="NO" name="footer">
    </frameset>
  </frameset>
  <frame src="right_frame.html" name="rightframe" scrolling="NO" marginwidth="0"
marginheight="0" noresize frameborder="NO">
</frameset>
<noframes> 
<body bgcolor="424A52" text="#FFFFFF">
</body>
</noframes> 
</html>

and the "midcontent" frame:

<html>
<head>
<title>Paradise Lost</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">


<!--
Popup Window
Version 2.0
Last Updated: May 7, 1999
Code maintained at: http://www.moock.org/webdesign/javascript/
Copy permission granted for non-commercial uses. Written by Colin Moock.-->


<SCRIPT LANGUAGE="JavaScript"> var javascript_version = 1.0;</SCRIPT>
<SCRIPT LANGUAGE="JavaScript1.1">  javascript_version = 1.1;</SCRIPT>


<SCRIPT LANGUAGE="JavaScript">

var newwin;

function launchwin(winurl,winname,winfeatures)
{
	//This launches a new window and then
	//focuses it if window.focus() is supported.
	newwin = window.open(winurl,winname,winfeatures);
	if(javascript_version > 1.0)
	{
		//delay a bit here because IE4 encounters errors
		//when trying to focus a recently opened window
 		setTimeout('newwin.focus();',250);
	}
}
</SCRIPT>
</head>

<body bgcolor="#000000" text="#000000">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
width="750" height="422">
  <param name=movie value="flash/rave_top.swf">
  <param name=quality value=high><param name="BGCOLOR" value="#000000">
  <embed src="flash/rave_top.swf" quality=high
pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"
type="application/x-shockwave-flash" width="750" height="422" bgcolor="#000000">
  </embed> 
</object> 
</body>
</html>
using a trunk build on win2K from 2002093010) and npswf32.dll (Shockwave Flash
6.0 r47) the page loads just fine. On macOSX using a trunk build from today
(20021002098) and Shockwave Flash 6.0 r29, the intro runs through its course and
then the secondary page displays. When that page displays the pinwheel remains
active even though objects are selectable. So, it looks like it is hung, but it
is still functional. It kind of looks like a timer or refresh of some sort.
Assignee: beppe → peterl
Peter opened a bug about the hang already, marking as a dup of bug 172172

*** This bug has been marked as a duplicate of 172172 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Test case URL loads just fine and plays well using the new Flash beta plugin
(7.0r2 as of this writing). I believe all of the flash performance bugs should
probably be retested with this installed, and probably marked RESOLVED.

Plugin link: http://www.macromedia.com/software/flashplayer/public_beta/
You need to log in before you can comment on or make changes to this bug.