Closed Bug 172237 Opened 17 years ago Closed 11 years ago

Japanese vertical text (using table width hack) is displayed incorrectly

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: kyae-young.kim, Assigned: smontagu)

References

(Blocks 1 open bug)

Details

(Keywords: intl, Whiteboard: [oracle-nls])

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020826

Japanese vertical text display incorrectly

Reproducible: Always

Steps to Reproduce:
      1) Load the test case
      2) Displayed two or one Janpanes characters at each row.
         It should be displayed one character for each row
      3) It works fine in IE 5.5 and Netscape 4.7
Summary: Japanese vertical text display incorrectly → Japanese vertical text is displayed incorrectly
Keywords: intl
QA Contact: ruixu → ylong
Summary: Japanese vertical text is displayed incorrectly → apanese vertical text is displayed incorrectly
Summary: apanese vertical text is displayed incorrectly → Japanese vertical text is displayed incorrectly
Whiteboard: [oracle-nls]
Are we determining that there's no line-breaking opportunity between those pairs
of characters (seems more likely, since I'm seeing it on Linux too), or are some
of the characters wide enough that they're wider than those pairs?
OS: Windows 2000 → All
Hardware: PC → All
Summary: Japanese vertical text is displayed incorrectly → Japanese vertical text (using table width hack) is displayed incorrectly
We are determining that there is no line-breaking opportunity before the fifth character, U+30C3 KATAKANA LETTER SMALL TU. This is correct according to http://www.unicode.org/reports/tr14/index.html#NS (but see the NOTE: at the end of the section)

In CSS3-Text terms, we could solve this by using line-break: normal instead of line-break: strict.
Assignee: tetsuroy → smontagu
Or word-break: loose; according to the new draft... (As always, comments welcome. :)
There is no line-breaking opportunity inside セッ, so the table is enlarged to make room for セッ, and becomes wide enough for トの, so トの is not broken despite that it would allowed if required.

Would there be a way to allow breaks before a NS character only if breaking is required to not force the resizing of the enclosing element ?

Adding masa as cc in case he'd be interested in taking over this.
Thank you Jean-Marc, and I forgot this bug, sorry.

I think that we should mark this to INVALID.

Because:

1. There are no reasons for breaking between the characters in any specs.

2. The hacked text cannot be wrapped automatically. It is too useless for both authors and readers.

3. The table width hack has very serious accessibility issue. Because Japanese vertical text direction is tb-rl. So, if authors need two or more lines, they need to write the text from the last line to the first line in source code, so, the screen readers cannot read the text correctly, probably. Therefore, all authors should not use this hack.

4. Most pages don't use this hack now. We can ignore this issue also in marketing.

5. There is a new hack for floated/positioned paragraph with word-break property in CSS3. But it is out of scope of this bug. And I don't know the sites which use such hacks.

6. Opera and Safari doesn't support this hack, so, we don't need to support this hack.

7. And the hacked text isn't rendered pretty on IE :-)
Let's close this as INVALID. There's no bug in the behavior.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.