stop distributing xbl form controls (forms.jar)

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

Trunk
mozilla1.9.2a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

16 years ago
Since we're not going to turn on XBL form controls anytime soon, we should stop
packaging forms.jar in the installer builds.
(Assignee)

Comment 1

16 years ago
Created attachment 103499 [details] [diff] [review]
patch
[Checkin: Comment 5]
(Assignee)

Comment 2

16 years ago
Created http://bugscape.mcom.com/show_bug.cgi?id=20723 for the changes to the
Netscape installer files.

Comment 3

16 years ago
r=blake

Comment 4

16 years ago
Comment on attachment 103499 [details] [diff] [review]
patch
[Checkin: Comment 5]

r=me on the idea of not packaging XBL Form Controls.  I don't by any means know
the ins and outs of packaging, but I presume that is what blake reviewed, so I
think you are covered.
(Assignee)

Comment 5

16 years ago
checked into the trunk.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
hm, shouldn't the GUI for the xbl-preference also be removed then? (in the debug
panel)

Comment 7

16 years ago
Created attachment 105550 [details] [diff] [review]
Removing GUI for the xbl-preference
[Moved to bug 412490]

Comment 8

16 years ago
This backout caused the default Mozilla to switch from classic to modern.

I checked this repeatedly to make sure it was the cause.
(Assignee)

Comment 9

16 years ago
mkaply, are you seeing that on an existing profile or a new profile?  Installing
over an existing build?

Comment 10

16 years ago
Any time you create a new profile, you have this problem.


You also see modern for all the profile manager stuff now.

Comment 11

16 years ago
Please reopen, cleanup is not complete. The preference itself should also be reset
(or ignored) as Mozilla now tries to use XBL forms, when enable, but due to the
missing forms.jar everything (such as Debug/Viewer Demos/#8 Forms) becomes a mess.

Comment 12

16 years ago
I am going to reopen this.

Alfred is correct.

You can't just remove the jar.

You need to remove the preference from the dialog and #if 0 the code in
CSSFrameConstructor and nsChromeRegistry so noone accidentally does this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

12 years ago
Assignee: bryner → nobody
Status: REOPENED → NEW
QA Contact: tpreston → layout.form-controls
Attachment #103499 - Attachment description: patch → patch [Checkin: Comment 5]
It seems <forms.jar> is (still) not packaged with Trunk Firefox/SeaMonkey/Thunderbird.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070315 SeaMonkey/1.5a] (nightly) (W2Ksp4)

But SeaMonkey still has that debug UI entry.
Fixed by bug 412490.
Status: NEW → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9
Attachment #105550 - Attachment description: Removing GUI for the xbl-preference → Removing GUI for the xbl-preference [Moved to bug 412490]
Attachment #105550 - Attachment is obsolete: true
(In reply to comment #12)

Ftr, CSSFrameConstructor part was removed by bug 473390.
Depends on: 412490, 473390
Flags: in-testsuite-
Target Milestone: mozilla1.9 → mozilla1.9.2a1
Created attachment 370216 [details] [diff] [review]
(Cv1) all.js: Remove obsolete preference
[Checkin: Comment 17]
Attachment #370216 - Flags: superreview?(roc)
Attachment #370216 - Flags: review?(roc)
Attachment #370216 - Flags: superreview?(roc)
Attachment #370216 - Flags: superreview+
Attachment #370216 - Flags: review?(roc)
Attachment #370216 - Flags: review+
Comment on attachment 370216 [details] [diff] [review]
(Cv1) all.js: Remove obsolete preference
[Checkin: Comment 17]


http://hg.mozilla.org/mozilla-central/rev/5979cfc7ead5
Attachment #370216 - Attachment description: (Cv1) all.js: Remove obsolete preference → (Cv1) all.js: Remove obsolete preference [Checkin: Comment 17]
Assignee: nobody → bryner
You need to log in before you can comment on or make changes to this bug.