Closed Bug 1723012 Opened 2 months ago Closed 2 months ago

Crash in [@ mozilla::layers::NativeSurfaceWaylandDMABUF::ObtainBufferFromPool]

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- fixed

People

(Reporter: kashav, Assigned: rmader)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/0fe55c2e-5d73-4366-a8fb-d5e100210727

Reason: SIGSEGV /SEGV_MAPERR

Top 10 frames of crashing thread:

0 libxul.so mozilla::layers::NativeSurfaceWaylandDMABUF::ObtainBufferFromPool gfx/layers/SurfacePoolWayland.cpp:448
1 libxul.so mozilla::layers::NativeSurfaceWaylandDMABUF::GetNextFramebuffer gfx/layers/SurfacePoolWayland.cpp:362
2 libxul.so mozilla::layers::NativeLayerWayland::NextSurfaceAsFramebuffer gfx/layers/NativeLayerWayland.cpp:541
3 libxul.so mozilla::wr::RenderCompositorNativeOGL::Bind gfx/webrender_bindings/RenderCompositorNative.cpp:519
4 libxul.so <webrender_bindings::bindings::WrCompositor as webrender::composite::Compositor>::bind gfx/webrender_bindings/src/bindings.rs:1298
5 libxul.so webrender::renderer::Renderer::draw_frame gfx/wr/webrender/src/renderer/mod.rs:4531
6 libxul.so webrender::renderer::Renderer::render_impl gfx/wr/webrender/src/renderer/mod.rs:1966
7 libxul.so webrender::renderer::Renderer::render gfx/wr/webrender/src/renderer/mod.rs:1708
8 libxul.so wr_renderer_render gfx/webrender_bindings/src/bindings.rs:614
9 libxul.so mozilla::wr::RenderThread::UpdateAndRender gfx/webrender_bindings/RenderThread.cpp:491

Maybe a regression of bug 1718569?

Severity: -- → S2
Flags: needinfo?(robert.mader)

Thanks. Yes, this exact trace can only occur since bug 1718569 and will either be fixed or change after bug 1720375 lands, thus marking as dependent.

Depends on: 1720375
Flags: needinfo?(robert.mader)
Regressed by: 1718569

This crash can't happen any more after bug 1718569, thus marking as fixed.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Assignee: nobody → robert.mader
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.