Closed Bug 172312 Opened 18 years ago Closed 16 years ago

slow slow flash until you drag the window title bar

Categories

(Camino Graveyard :: Plug-ins, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: grichie, Assigned: sfraser_bugs)

References

()

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021001
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021001

If a flash animation needs a bit more CPU, the browser gets slower, but if I use
the scrollbar on the right, everything works fine. It happens in all Mozilla
browsers. 
Check out an example: http://www.privatemoon.com/artists/kartel/preview
(I have an IBook600 with OSX10.2) 



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Richard, if the animation needs more CPU time, naturally the browser will
allocate more CPU time to it and the browser will get slower. That isn't a bug.
Also, dragging the scroll elevator stops other processing until it released.
That isn't necessarily a bug, either.

The performance of that page using Chimera/2002100104 on 10.1.5 is abysmal
compared to IE, though.
privatemoon.com appears to be dead. Is there another site that shows this?
Assignee: bnesse → sfraser
I can still access that URL, Simon, and performance is still strangely poor
compared to FizzillaMach/2003021203. It stutters severely.
Summary: Slow Flash animation if it needs a bit more CPU, but works ok if I grab the scrollbar → Slow Flash animation if it needs a bit more CPU, but works okay if I grab the scrollbar
this is bad... almost to the point of camino hanging... G4/400 (with itunes
running in the background) and my commands (cmd-n, cmd-w or selecting the menu)
were delayed a good minute or two. There is no such delay on the mozilla side.

Confirming and raising severity a bud due to the almost (and possibly perceived)
hang
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
This bug has some similatrities with bug:
http://bugzilla.mozilla.org/show_bug.cgi?id=204379
This bug seems to have great similarities with Bug 204379.

Camino seems to have some major issues with rendering large/complex flash movies
while other browsers such as IE, Safari and Firebird have no problem what so ever.
with 2003-08-12-02 & Flash 7 beta player thigns are better (not feeling like I'm
going to crash) but the window is still abnormally unresponsive. 
still true with 2003090102 on 10.2.6
Try this: load up the URL and then grab the title bar of the window. Suddenly
the flash anim speeds up dramatically. That's very very odd....
Summary: Slow Flash animation if it needs a bit more CPU, but works okay if I grab the scrollbar → slow slow flash until you drag the window title bar
Blocks: 225397
A complete shot-in-the-dark:  Could this bug be related to bug 222972 in some
way?  The frame drawing bug can be worked around by slightly resizing the
window.  This seems similar to the Flash speedup after moving the titlebar,
reported in comment #9.

Then again, Flash has been slow in Camino long before Panther.
Test URL is dead.
Complex flash movies hangs my firefox easylly, the performance in Safari is much
better, I think its related with bug 106397, cause when you are on a website
with lots of animation, like http://www.fox.com/24/ and keep the mouse button
pressed you can se things moving faster.

Maybe it should be mark as duplicate.

Yeah something really needs to done about flash performance soon before Camino
either hits .9 or 1.0 cause our current behaviour is and always has been un
acceptable for me, it's the only reason why I still use Safari in some cases.
First let’s get a new example URL here and see if Camino is still slower than
Mozilla.
I see this problem on the front page of http://www.teamxbox.com , where there is
often a largish FLASH anim.

Hopefully that will work as an example...
Marking WFM using 20050130 NB, my guess is this was fixed with the CFMessage fix
Simon/Geoff did on gecko event handling.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.