Closed Bug 204379 Opened 17 years ago Closed 15 years ago

Web page with multiple Flash movies (and big object movement) causes Camino to render the Flash badly.

Categories

(Camino Graveyard :: Plug-ins, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: camino, Assigned: peterlubczynski-bugs)

References

()

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030503 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030503 Camino/0.7+

I used to have a website which contained 3 pretty big flash movies, and they all
had simultanios coninuosly moving objects.

Now what i learned was that Camino is able to handle single flash movies
perfetctly. But when the number of flash movies in a single webpage gets higher
than two, especially when there are big object movements in the movie, camino
tempts to skip A LOT OF frames.

It just looks awfull. My G4 533 mac ins't slow and used to render flash pretty
darn good in OS 9 compared to what Camino is doing. This issue has been in
Camino since the beginning and i really think somebody or someone shoudl have a
look at this very nasty issue.

Reproducible: Always

Steps to Reproduce:
Go to any webpage with multiple flash movies containing big object movements.
Actual Results:  
Camino skips frames of the flash movie.

Expected Results:  
Camino should render any flash movie fluidly.
Jasper, how is the performance of this page in other browsers such as Mozilla,
Safari, and IE?
Keywords: perf
Summary: Webpage with multiple flash movies (and big object movemenyt) causes camino to render the flash badly. → Web page with multiple Flash movies (and big object movement) causes Camino to render the Flash badly.
I always use http://surface.yugop.com/ as a benchmark for flash performance on
enny platform or browser. It has huge flash movies with big motion and has
several movies on one page.

- Mozilla/Phoenix (1.4a) renders the pages flawlessly, suer it uses all my cpu
cycles, but everything (most of the things) look great.
- Safari also renders the pages great, everything is fluid.
- IE has always rendered pages ok.

But as I already said Camino skips frames all over the place.
I'm going to confirm this bug because I'v done testing at
http://surface.yugop.com/ on on my Blue and White G3 (400mhz... Not a speed
deamon) Safari and Mozilla play the flash perfectly while Camino is very slugish.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is anybody looking into this? Please do, it's a shame Camino still isn't able to
handle flash elements as it should.
You have got to be kidding me!

Macromedia just released a new public beta flash player v7, and they claim it's
15/70% faster than the previous plugin.

http://www.macromedia.com/software/flashplayer/public_beta/

In other browsers such as Safari and even other Gecko based browsers you notice
the difference especially since my CPU isn't taken over anymore when viewing
some really intesive flas movies such as http://surface.yugop.com/. But Camino
is still having a really hard time playing even the simplest large movies.

Please, pretty please with cream and sugar on top. Could someone please please
look into this really embarrasing problem. This unexceptable.
Firebird (latest version) for Mac is so much better in rendering flash content I
can't even believe they both use the same rendfer engine, they can't be. Just
try and you will see what I mean.

Where Camino skips frames all over the place and flash even hangs the
application, Firebird is having no problems what so ever. 

This is really starting to piss me of.
Since no one sees to really care, could somebody just set it to WONTFIX?
jasper, comments like that won't get this bug fixed any faster. it's a matter of
resources. 
I apologize for writing such a stupid remark. Won't happen again, this bug is
just awful.

I took the opertunity to take closer look at what's going wrong here. First I
had a look at Camino rendering flash pages (the http://surface.yugop.com/ page)
and noticed that Quartz is realy realy slow, there are enormous time gaps
between screen updates. The screen updates are incredibly slugish. It appears to
me as if Quartz isn't getting the information fast enough. When I do the same
thing with Mozilla everything renders ike a charm.

I also had a look with ThreadViewer and here you can see that Camino is
incredibly buisy with doing al kinds of things except rendering flash content
fast enough. Where Mozilla uses only one thread (to the max) when rendering the
page Camino is using two threads (to the max). It appears as if the allocation
of cpu cycles is doing strange things when a flash plugin is loaded.

I also noticed that when you put Camino in the background it's a lot more active
than mozilla.
have you searched for other bugs like this? 

I recall there being a bug that would hide itself when some kind of debug 
Quartz settting was turned on. Dunno....AOL took back all its Macs so I can't 
even look at the problem.
Perhaps a solution lies in Bug 132759. After reading this bug it seems to me
it's the same issue, the only difference is that it's for Windows and not for
Mac. But still the issues of performance described are 99.9 % the same.
It seems as if many people think it's just due to the fact a lot of people have
slow macs. Which is really stupid because every other browser than Camino
including Mozilla itself and IE are better at handeling flash content than
Camino on pre G3 macs. 

No the new flash plugin doesn't solve the slow rendering of Flash content in
Camino. No it's not due to a slow Mac since other browsers are perfcetly capable
of rendering the same content without a problem on pre G3 macs.

Some other bugs:
Bug 106397 - Fizzilla's performance in displaying Flash files is suboptimal
Bug 172172 - 100% cpu, mozilla
Bug 16125 - flash content drawn on top of chrome, this is still an issue in Camino
Bug 43506 - 2 movies on 1 page go bad has to with mozilla cache.

Pretty please with everything on top, could some developer of Mozilla or Camino
have a good look  at this. Camino isn't the fastest rendering browser on OS X as
long as this bug isn't fixed, it's actually the slowest at the moment.
In these cases, being other browsers from the same company, isn't it possible to just take parts of 
codes from where it works?
Blocks: 225397
Confirm this still occurs (on jaguar). I see performance being not as good as
Mozilla even when there's only one flash movie , although it's more subtle. Also
I noticed performance degradation sometimes was accompanied by heavy disk access.
No longer blocks: 225397
Blocks: 225397
Could this bug possibly be related to, or the same as, Bug 182087, which deals
with the same problem, but with the RealOne Plug-in, instead of Flash?
I wonder if Mac SeaMonkey and Firebird will see a Flash performance regressions
if they begin compiling against Cocoa and NSQuickdrawView?
Is this any better now that smfr's patch for bug 271050 has landed?  (Perhaps
someone needs to query all of the old Flash performance bugs?)
Tried testcase http://surface.yugop.com/ with Camino 2005011808 (v0.8+) and did
not notice any significant skipped frames on the different samples.  I'm
guessing they all ran better than 20-30 fps on my G5 1.8 dual FX5200.
Marking WFM using 20050130 NB, I think this was fixed by the CFMessage fix
Simon/Geoff made on Cecko event handling.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.