XIM: over-the-spot - Preedit area is located at the top of textarea

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: kazhik, Unassigned)

Tracking

({inputmethod, intl})

Trunk
x86
Linux
inputmethod, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Preedit area is located at the top of textarea even when
the editing point is the middle of textarea.

Steps to reproduce:
(1) Turn on kinput2 and enter Japanese text.
(2) Activate another window and come back.
(3) Enter text.

Related: bug 53990

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → kasumi

Comment 1

16 years ago
Can anyone reproduce this problem?

Comment 2

16 years ago
will look into this problem.
Assignee: yokoyama → katakai

Comment 3

16 years ago
Assigned to myself.

This problem is still reproducible on the latest binary
with over-the-spot input style.
Status: NEW → ASSIGNED
Summary: Preedit area is located at the top of textarea → XIM: over-the-spot - Preedit area is located at the top of textarea

Comment 4

13 years ago
There is a patch for bug 271815 which works perfectly with gtk2 and
over-the-spot method.

But bug 271815 isn't ever assigned, so we shouldn't hope having it included in a
near Firefox release.
Masaki, could you test and review it ?

Comment 5

13 years ago
comment 4:
GTK+2 doesn't support over-the-spot.
So GTK+2 build doesn't have this problem.
QA Contact: kasumi → i18n
INVA for gt2, per comment 5. And now, nsGtkIMModule specifies correct caret position by the fix of bug 271815.
Assignee: masaki.katakai → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Component: Internationalization → Widget: Gtk
QA Contact: i18n → gtk
Resolution: --- → INVALID
Duplicate of this bug: 323951
You need to log in before you can comment on or make changes to this bug.