Closed Bug 1723563 Opened 6 months ago Closed 5 months ago

Ubuntu & Orca screen reader - Stops working after first restart

Categories

(Core :: Disability Access APIs, defect)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- wontfix
firefox93 --- verified

People

(Reporter: pablo.muir, Assigned: eeejay)

References

Details

Attachments

(1 file)

Description
After first restart using orca screen reader the file menu is not accessible using the alt key.

Tested and affects all these Os
Ubuntu 20

Affected
Firefox nightly 92.0a1 affected
Firefox beta 91.0b9 not affected
Firefox release 90.0.2 not affected

Preconditions
have orca installed and running

Steps
-Create new profile and launch firefox
-press alt key (notice it says "left alt, file menu", and you can press right key, and then down key... and it speaks.
-press control Q to close firefox
-Launch again firefox, use the same profile, and press "alt" key

Expected result
it should say "left alt, file menu" . and you should be able to navigate the menu, and you should hear each option

Actual result

  1. it only says "left alt", it did not say file menu.

  2. randomly it can do 2 things:
    a) when you press right key and then the down key, it shows the menus but orca does not say anything that is selected for example it is not speak "edit menu" nor "settings"
    b) when you press right and down key, no menu is shown, firefox does nothing.

notes: The same thing happens if you

  1. run a new profile
  2. go to about:About
  3. press tab key

on first run it reads the options, but if you close firefox and launch it again, it does not read the content inside about:about

Severity: -- → S3
Keywords: access
Summary: Ubuntu & Orca screen reader - File menu not accessible after first restart → Ubuntu & Orca screen reader - Stops working after first restart
Component: Disability Access → Disability Access APIs
Keywords: access
Product: Firefox → Core

I was able to reproduce. a not-so-quick biesection found the issue to be in March 22nd, 2018. Nothing obvious in that range. One unrelated ATK patch. Will investigate further.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=68464218a41a5350ffa926e1b5d77fde75bc4e01&tochange=8bf380faae74e4921be6000496ca09d4a2c44e8d

I suspect this is a regression from bug 1447719. Setting browser.startup.blankWindow seems to resolve this.

Firefox shows a blank window and then swaps it for the real thing for
percieved startup performance. This causes us to throw away the
activated state stored on the initial root widget. Instead of storing
the state, we should retrieve it from widget.

Assignee: nobody → eitan
Status: NEW → ASSIGNED
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b70a28c9a533
Get activated state from widget instead of storing it. r=Jamie
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9c0a125e6b2
Get activated state from widget instead of storing it. r=Jamie
Regressions: 1725519
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Flags: needinfo?(eitan)

The patch landed in nightly and beta is affected.
:eeejay, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.
If yes, don't forget to request an uplift for the patches in the regression caused by this fix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(eitan)

This patch is not 100% simple, and since this bug has existed for 3 years, there is no hurry to uplift it to beta.

Flags: needinfo?(eitan)

Verified fix on todays nightly 93.0a1 on Ubuntu 20 64bit, after restart using the same profile i can hear left alt> file menu, and the options in the menu pressing arrow keys

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.