Closed Bug 1723729 Opened 1 year ago Closed 1 year ago

Talos tart attempts to use chrome://tart/content/tart.ico as a favicon, but that doesn't exist.

Categories

(Testing :: Talos, defect, P2)

Default
Desktop
All
defect

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: Gijs, Assigned: mconley)

References

Details

Attachments

(3 files)

As in summary. See bug 1721627 for some context, and https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&revision=a670f5679e0be52691261833eab3fb6beac8f044&selectedTaskRun=P_Thv5kRQQuM1oxXZyNB9w.0 for the infra failure.

I... don't know how this impacts the results, but it's broken. I'm particularly worried because the title of https://searchfox.org/mozilla-central/source/testing/talos/talos/tests/tart/addon/chrome/blank.icon.html#4 specifically says "Just another blank TART page with an icon", and, well, there's no icon...

The reference in https://searchfox.org/mozilla-central/rev/4f05a46731c1f7f111ec7a41ce38a34594aa0d37/testing/talos/talos/tests/tart/tart.html#5 appears to work, AFAICT. I think the problem is what happens when we try to load chrome://tart/content/blank.icon.html, which in turn tries to load chrome://tart/content/tart.ico. I'm additionally confused because https://searchfox.org/mozilla-central/source/testing/talos/talos/generate-tart-xpi.html does appear to attempt to package the file, but I don't know where the xpi we actually run with comes from or how to inspect it.

Mike, could you take a look at what's wrong here, and what the impact on the test would be?

Flags: needinfo?(mconley)
Priority: -- → P2

The TART WebExtension tries to use tart.ico inside of blank.icon.html,
but it wasn't included in the WebExtension, so that results in a
missing favicon.

This copies tart.icon from the root of the tart test directory, where
the test launcher document (which is, perhaps confusingly, not part
of the add-on) uses it.

Assignee: nobody → mconley
Status: NEW → ASSIGNED

These documents and scripts were used to generate the add-ons for the tresize
and tart Talos tests before the great WebExtension conversion.

Nowadays, if people really want to install these tests locally, they can
go to about:debugging, use Load Temprary Add-on, and browse to the manifest
of the add-on folder.

Depends on D122378

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a990e969dee8
Make sure to package tart.icon with TART WebExtension. r=perftest-reviewers,jmaher,alexandru.irimovici
https://hg.mozilla.org/integration/autoland/rev/5eab3a1fd9b2
Remove tart.ico from broken chrome:// URI allowlist. r=Gijs,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/d947c22d3410
Remove old Talos XPI generation scripts and documents. r=jmaher,perftest-reviewers,alexandru.irimovici
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Flags: needinfo?(mconley)
See Also: → 1725504
You need to log in before you can comment on or make changes to this bug.