Closed Bug 1724637 Opened 1 year ago Closed 1 year ago

upon opening a NNTP message the contents does not always load

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: chriechers, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [addon:Allow HTML Temp])

Attachments

(1 file)

Opening NNTP messages causes these messages in the error console:

Error: Internal error: Type IconPath not found Schemas.jsm:1602:13
get targetType resource://gre/modules/Schemas.jsm:1602
normalize resource://gre/modules/Schemas.jsm:1609
<anonymous> resource://gre/modules/Schemas.jsm:1508
withChoices resource://gre/modules/Schemas.jsm:601
normalize resource://gre/modules/Schemas.jsm:1500
r resource://gre/modules/Schemas.jsm:2014
withPath resource://gre/modules/Schemas.jsm:639
checkProperty resource://gre/modules/Schemas.jsm:2013
normalize resource://gre/modules/Schemas.jsm:2086
fixedArgs resource://gre/modules/Schemas.jsm:2691
map self-hosted:221
checkParameters resource://gre/modules/Schemas.jsm:2686
stub resource://gre/modules/Schemas.jsm:2792
setIcon moz-extension://a2efe7c7-487a-4a71-8253-abcb15bd747e/js/vapi-background.js:716
setIcon moz-extension://a2efe7c7-487a-4a71-8253-abcb15bd747e/js/vapi-background.js:846
AsyncFunctionNext self-hosted:692
Did you try to stream an nttp message? Doens't work. See bug 545365. MimeMessage.jsm:121:13
onDataAvailable resource:///modules/gloda/MimeMessage.jsm:121
TypeError: aPart is null MimeMessage.jsm:137:7
stripEncryptedParts resource:///modules/gloda/MimeMessage.jsm:137
wrapCallback resource:///modules/gloda/MimeMessage.jsm:213
onStopRequest resource:///modules/gloda/MimeMessage.jsm:95
Did you try to stream an nttp message? Doens't work. See bug 545365. MimeMessage.jsm:121:13
onDataAvailable resource:///modules/gloda/MimeMessage.jsm:121
TypeError: aPart is null MimeMessage.jsm:137:7
stripEncryptedParts resource:///modules/gloda/MimeMessage.jsm:137
wrapCallback resource:///modules/gloda/MimeMessage.jsm:213
onStopRequest resource:///modules/gloda/MimeMessage.jsm:95

For some messages the body contents does not load at all - see attached screenshot.
Seen with TB91 candidate build 64-bit on Linux. Also happens with TB91 beta6.
I'm not exactly sure when this started, possibly with beta6.
When this happens, going back one message by pressing B, and going forward again by pressing N, the message usually loads properly at the second attempt.

Example:
News server: news.aioe.org
News group: alt.comp.software.thunderbird
Any thread will do.

Keywords: regression
Whiteboard: beta
Blocks: tb91found

WFM over here on linux.
Did you try in safe-mode?

I've had zero issues, consistently.

Crap, no problem in safe mode. It looks like the 'Allow HTML Temp' add-on is the culprit.
I did upgrade a TB78 profile to TB91 Candidate with 'Allow HTML Temp' present, and since saw the problem. I also installed 'Allow HTML Temp' in a different profile with TB91 beta6, and since saw the problem. I'll follow up with the add-on author. Sorry about the noise.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
Whiteboard: beta → [addon:Allow HTML Temp]

Which version of Allow HTML Temp is/was installed, when these problems occur? In my case it was initially not automatically updated to the 91-compatible version series after "updating" Thunderbird from 78 to 91.

The problem happened with two profiles, and both now have Allow HTML Temp 7.0b3 installed.

  1. TB91.0 candidate upgraded from TB78.12.0. I believe Allow HTML Temp updated automatically to v7.0b3.
  2. TB91.0 beta6. Allow HTML Temp was installed manually, after realizing that there's now a compatible version.
    Thanks for the quick response.
You need to log in before you can comment on or make changes to this bug.