Closed Bug 1725144 Opened 1 year ago Closed 1 year ago

composeAction API: “Error: Internal error: Type IconPath not found”

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird92+ fixed)

RESOLVED FIXED
93 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird92 + fixed

People

(Reporter: tdulcet, Assigned: TbSync)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

browser.composeAction.setIcon() throws these errors:

Error: Internal error: Type IconPath not found Schemas.jsm:1602:13
Uncaught DOMException: An exception was thrown debugger eval code:1:23

mozregression returns this result:

2021-08-11T03:57:18.112000: INFO : Narrowed nightly regression window from [2021-05-18, 2021-05-21] (3 days) to [2021-05-20, 2021-05-21] (1 days) (~0 steps left)
2021-08-11T03:57:19.163000: DEBUG : Found commit message:
Bug 1712058 - Flip default value for browser_style in cloudFile API from true to false and fix some descriptions and type definitions. r=mkmelin

Differential Revision: https://phabricator.services.mozilla.com/D115600

2021-08-11T03:57:19.163000: INFO : The bisection is done.

It would be great if the fix for this regression could be uplifted to TB 91, as it is affecting an add-on I just published to ATN.

Keywords: regression
Regressed by: 1712058

I get the same error for messageDisplayAction:

browser.messageDisplayAction.setIcon({
  path: {
    64: "images/myimage.png",
  },
  tabId: currentTabId,
});

Bug still present in TB 91.0.1

Assignee: nobody → john
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Target Milestone: --- → 93 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9753440e197a
Fix schema definitions of action buttons involving IconPath type. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Time for uplift requests?

Flags: needinfo?(john)

Comment on attachment 9236873 [details]
Bug 1725144 - Fix schema definitions of action buttons involving IconPath type. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Icons of action buttons cannot be changed

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
None

Flags: needinfo?(john)
Attachment #9236873 - Flags: approval-comm-beta?
Duplicate of this bug: 1727988

Comment on attachment 9236873 [details]
Bug 1725144 - Fix schema definitions of action buttons involving IconPath type. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9236873 - Flags: approval-comm-beta? → approval-comm-beta+

Uplift to 91?

Comment on attachment 9236873 [details]
Bug 1725144 - Fix schema definitions of action buttons involving IconPath type. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Icons of action buttons cannot be changed

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
None

Attachment #9236873 - Flags: approval-comm-esr91?

Comment on attachment 9236873 [details]
Bug 1725144 - Fix schema definitions of action buttons involving IconPath type. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9236873 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.