Change "Custom wav file" to "Custom sound file" in MailNews prefs

VERIFIED DUPLICATE of bug 266192

Status

SeaMonkey
MailNews: Message Display
--
trivial
VERIFIED DUPLICATE of bug 266192
16 years ago
13 years ago

People

(Reporter: Greg K., Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: File to patch is chrome/en-US/locale/en-US/messenger/pref-mailnews.dtd)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Presuming Mozilla can play sound formats other than wav, Mozilla shouldn't refer
specifically to a single proprietary sound format in it's new-mail-sound prefs.
Instead of "Custom wav file", we should use "Custom sound file".
(Reporter)

Comment 1

16 years ago
Created attachment 101670 [details] [diff] [review]
Patch
(Reporter)

Updated

16 years ago
Keywords: patch, review
seth, would this be in your area? reassign if needed.
Assignee: ben → sspitzer
Component: Preferences → Mail Window Front End
Product: Browser → MailNews
QA Contact: sairuh → olgam

Comment 3

16 years ago
I believe we can only handle .wav files at the moment?
Hence why that wording was picked.

Comment 4

16 years ago
> I believe we can only handle .wav files at the moment?
> Hence why that wording was picked.

Currently it says "wav" not ".wav" file.

If the wording is going to be changes, could the capitalisation be sorted out 
at the same time?

"System New Mail Sound" isn't consistent with "Custom wav file".

Comment 5

16 years ago
The Mac nsISound implementation can actually play any sound format that
Quicktime handles (e.g. aiff, wav, mp3 etc). Yes, you could set this sound file
to be a 5-minute MP3  ;)

Updated

16 years ago
QA Contact: olgam → stephend
(Reporter)

Comment 6

15 years ago
Looks like my original patch correctly; it replaces the whole DTD file. I'll try
to make another.

Should this be a Mac-only change, or can Mozilla handle multiple non-WAV formats
on all platforms?
(Reporter)

Updated

15 years ago
Whiteboard: File to patch is chrome/en-US/locale/en-US/messenger/pref-mailnews.dtd
Product: Browser → Seamonkey

Comment 7

13 years ago
*** Bug 271485 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
I'll add this into the next patch for bug 266192 so marking as a dupe

*** This bug has been marked as a duplicate of 266192 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.