Closed Bug 1725432 Opened 4 months ago Closed 3 months ago

Disable toolbar button when new screenshots UI is showing

Categories

(Firefox :: Screenshots, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: emmamalysz, Assigned: kajalsah107)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When screenshots.browser.component.enabled is true and we bring up the screenshots UI, we don't disable the screenshots button. We need to send the toggle-screenshot-disable notification when we open the tab dialog box https://searchfox.org/mozilla-central/rev/3a8091d1c29473a0839ad7a5810028f41363fe2e/browser/components/screenshots/ScreenshotsUtils.jsm#20-25 and when we close it https://searchfox.org/mozilla-central/rev/3a8091d1c29473a0839ad7a5810028f41363fe2e/browser/components/screenshots/content/screenshots.js#47,94,140.

It may make sense to have a close() helper in screenshots.js that handles the notification and window.close() function each time.

Assignee: nobody → kajalsah107
Attachment #9236832 - Attachment description: WIP: Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster → Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster
Status: NEW → ASSIGNED
Attachment #9236832 - Attachment description: Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster → WIP: Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster
Attachment #9236832 - Attachment description: WIP: Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster → Bug 1725432 - Disables toolbar button when new screenshots UI is showing. r?emalysz,sfoster
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch
Flags: qe-verify+

I was not able to reproduce this issue on Firefox 93.0a1 (2021-08-12) but I noticed something else, if I toggle the screenshot button, immediately it becomes disabled, then change the tab (click on the next tab) and after this came back to the initial tab where you take a screenshot, now the screenshot button is enabled. This happens on latest nightly and on 93.0b7 beta builds. This is expected or is related to this issue itself? Thanks!

Flags: needinfo?(emalysz)

I'll file a separate bug for that

Flags: needinfo?(emalysz)
You need to log in before you can comment on or make changes to this bug.