Closed Bug 1725562 Opened 1 year ago Closed 1 year ago

Default "open with" program not remembered

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1690395

People

(Reporter: Mikeyy, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

When e-mail contains attachment, for example .xlsx file, when you click on it, it opens Thunderbird dialog in which you decide what to do with file.

  • open with: list of programs
  • save file

At bottom there is checkbox which remembers your choice for future openings of same file type.

Well, that checkbox isn't doing anything since TB 91. This is regressing, since it's working properly TB 78.

Actual results:

Thunder dialog open every time, even when you decided file should be directly opened in some application.

Expected results:

File should open in application selected for that file type.

But it worked for you in 78?

I'd be very surprised if this had not be caught in testing. Does it also happen in safe mode https://support.mozilla.org/en-US/kb/safe-mode-thunderbird ?

Blocks: tb91found
Component: Untriaged → General
Flags: needinfo?(mihovil)
Summary: Default open with not remembered → Default "open with" program not remembered

Yes, it worked in latest 78.x.x which I had before I upgraded to TB 91 this morning.
It's same in "Troubleshoot mode" which I guess is old "Safe mode".

I'm using localized HR Thunderbird versions if that affects anything.

Tested with .xlsx and .docx files, with default opening program LibreOffice.

What I also don't like, is that there is no prompt for PDF files any more. Can't choose between opening in TB PDF.js or external app.

Flags: needinfo?(mihovil)

Went to Preferences / General / Files and attachments and change default app for PDF to "Always ask".
Then I tried to open PDF from attachment, and I got popup window asking me to choose what app to use or save file. That's good and expected. I choose external PDF app, marked "always use that app" checkbox and opened. Next time I tried to open PDF it remembered my choice.

Tried same for .xlsx and .docx and it isn't working.

This is a very known issue (bug 453455 which got worse with the move to e10s, I'm told it's super hard to fix)

No longer blocks: tb91found
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455

First post of bug 453455 is vague so I'm not really sure what that bug is about, but looking at two attached pictures, it seams to me that bug is referring to "grayed out" (unable to click on) "Do this automatically for files like this from now on." checkbox.

My problem isn't grayed out checkbox. I'm offered checkbox and can click on it, but next time I want to open file TB isn't respecting my default choice and it's opening that dialogue again. All default applications are set, and were working this morning on 78.x before I upgraded.

I know that bug 453455 with grayed out checkbox exists since it happens to me sometimes (with new installs), but eventually I managed to set default apps for all file types I regularly open.

Correct. It's still the same bug, and what you've reported is what we've been unsuccessfully trying to find a solution for.

Blocks: tb91found
No longer blocks: tb91found
Duplicate of this bug: 1733992
Duplicate of this bug: 1734395

We have Bug 1690395 for tracking the Thunderbird fallout.

Duplicate of bug: 1690395
You need to log in before you can comment on or make changes to this bug.