Closed Bug 1725680 Opened 2 months ago Closed 19 days ago

Back button sometimes goes to the wrong page in Nightly

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED FIXED
94 Branch
Fission Milestone MVP
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox91 --- disabled
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: jrmuizel, Assigned: smaug)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: fission-hard-blocker)

Attachments

(1 file)

I had a situation where the following happened:

I was able to reproduce this a couple of times in a row, but can't anymore.

I believe I've noticed this kind of thing happening before, but this was the first time I was able to reproduce it to confirm it wasn't confusion on my part.

Which version of Firefox are you using, and is Fission enabled?

Flags: needinfo?(jmuizelaar)

93.0a1 (2021-08-12) and Fission is enabled

Flags: needinfo?(jmuizelaar)

This sounds like the issue jesup has seen.

I wish there was some way to reproduce.

Fission Milestone: --- → ?
Flags: needinfo?(rjesup)

Is there something I should check for if it happens again?

Flags: needinfo?(bugs)

Running the script from http://mozilla.pettay.fi/moztests/shistory.log.txt in the browser console when the problematic page is in the foreground tab might reveal something.
Feel free to send the output to me, if you don't want to attach it to this bug.

The output looks something like
index: 1
requestedIndex: -1
count: 2
Entry[0], originalURI: null, uri: about:newtab, ID: 4697
Entry[1], originalURI: null, uri: http://mozilla.pettay.fi/moztests/shisto..., ID: 4833

Flags: needinfo?(bugs)
Blocks: backtraps
Severity: -- → S3
Fission Milestone: ? → MVP
Priority: -- → P3
Whiteboard: fission-soft-blocker

Jeff or Randell, have you seen this Back button bug recently?

I haven't been able to repro.

Flags: needinfo?(jmuizelaar)

No, but I don't see it/notice it often enough to say that it's been fixed.

Flags: needinfo?(jmuizelaar)

Olli, Randell says he still see this Back button bug "every few days". Nika says this bug is important.

I'm tentatively assigning this bug to you. If you think someone else should investigate, let me know.

Assignee: nobody → bugs
Flags: needinfo?(rjesup) → needinfo?(bugs)
Priority: P3 → P2

jesup, could you send the relevant session history state when you see this (see comment 5).

Flags: needinfo?(bugs) → needinfo?(rjesup)

Data was sent

Flags: needinfo?(rjesup)
See Also: → 1731013
Duplicate of this bug: 1731013
Whiteboard: fission-soft-blocker → fission-hard-blocker

From Bug 1731013 Comment 3. This is regressed by Bug 1697905

Regressed by: 1697905

Using requestedIndex on the child side is hard, because there are race conditions when a session history load is triggered
and at the same time a non-session history load commits a new active entry.

Attachment #9242910 - Attachment description: WIP: Bug 1725680, requested index should be used only by the nsSHistory (and related code in CanonicalBrowsingContext), r=peterv → Bug 1725680, requested index should be used only by the nsSHistory (and related code in CanonicalBrowsingContext), r=peterv
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0459d02e5ee5
requested index should be used only by the nsSHistory (and related code in CanonicalBrowsingContext), r=peterv
Status: NEW → RESOLVED
Closed: 19 days ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Blocks: 1734858
You need to log in before you can comment on or make changes to this bug.