Closed Bug 1725873 Opened 2 months ago Closed 2 months ago

Reduce toolbar bookmark menu padding in compact mode

Categories

(Firefox :: Theme, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: yoasif, Assigned: yoasif)

References

Details

Attachments

(7 files)

The increased size of the bookmark toolbar menu (the one you can add as an icon that displays all of your bookmarks) is a common complaint about proton. I think we should use the unsupported compact mode to address this.

See Also: → 1725012
Assignee: nobody → yoasif
Status: NEW → ASSIGNED
Type: defect → enhancement
Attached image image.png

Suggested revision for same compactness as Firefox 78 ESR:

[uidensity=compact] menupopup > menuitem,
[uidensity=compact] menupopup > menu {
    padding-block: 2px;
}

Note: only tested on Windows.

In sum, all the menus I checked look okay with this change.

Attachment #9236349 - Attachment description: Bug 1725873 - Reduce toolbar bookmark menu padding in compact mode. r=mconley → Bug 1725873 - Reduce toolbar bookmark menu padding in compact mode. r?mconley
Attachment #9236349 - Attachment description: Bug 1725873 - Reduce toolbar bookmark menu padding in compact mode. r?mconley → Bug 1725873 - Reduce menu panel padding in compact mode. r?mconley
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/108a81c39b3d
Reduce menu panel padding in compact mode. r=dao
Blocks: 1727067
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

I like this change, thanks!

Duplicate of this bug: 1729790
You need to log in before you can comment on or make changes to this bug.