Closed Bug 1725950 Opened 2 months ago Closed 2 months ago

The "Empty" bookmark folder label is no longer greyed out in the Bookmarks Toolbar and in the Other Bookmarks

Categories

(Firefox :: Bookmarks & History, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox91 --- unaffected
firefox92 --- verified
firefox93 --- verified

People

(Reporter: simona.marcu, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Environment:]

Mac 10.15
Ubuntu 20.04
Windows 10 x64

Firefox 92 beta 4
Nightly 93.0a1

[Steps:]
  1. Open Firefox.
  2. Open the Library window and create a new folder for each of the locations: Bookmarks Toolbar, Bookmarks menu, Other Bookmarks - leave it empty
  3. Open Application Menu -> More Tools ->Customize toolbar...-> place the Bookmarks menu near the URL Bar.
  4. Go to each of the newly created folders, click on them and observe the "Empty" bookmark folder label.
[Actual Result:]

The "Empty" bookmark folder label is only greyed out in the Bookmarks Menu.

[Expected Result:]

The "Empty" bookmark folder label should be greyed out in the Bookmarks Menu, Bookmarks Toolbar, and Other Bookmarks.

[Notes:]

This issue is not reproducible on Firefox 91.

Found commit message:
Bug 1703051, apply proton panel styling to other bookmarks dropdown and overflow menu in bookmarks toolbar r=desktop-theme-reviewers,mconley,jaws,harry
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1e8ff38398ac6a98d0a0b5668a598206ed084688&tochange=9e5ec8c60805229571fb0b1a2b59f1fc53100cf2

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4e2ba0c4c187
use panel disabled color for disabled bookmark '(empty)' items, r=emalysz
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Comment on attachment 9236673 [details]
Bug 1725950 - use panel disabled color for disabled bookmark '(empty)' items, r?emalysz

Beta/Release Uplift Approval Request

  • User impact if declined: Confusing UI for empty folders, as the item looks like it can be used but is not in fact usable
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: N/A
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Single added CSS rule
  • String changes made/needed: No
Attachment #9236673 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified as fixed using the latest Nightly 93.0a1 on Windows 10 x64, Ubuntu 20.04, and macOS Big Sur 11.5.

Comment on attachment 9236673 [details]
Bug 1725950 - use panel disabled color for disabled bookmark '(empty)' items, r?emalysz

Approved for 92.0b6.

Attachment #9236673 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on the latest Firefox 92 beta 6 - verified on macOS Big Sur 11.5, Ubuntu 20.04, and Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.