Closed Bug 1726153 Opened 3 years ago Closed 2 years ago

Icons in PDF are rendered with scanlines

Categories

(Firefox :: PDF Viewer, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1269455
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix

People

(Reporter: csasca, Unassigned)

Details

Attachments

(2 files)

Attached video pdf rendering.webm

Affected versions

  • Firefox 91.0.1
  • Firefox 92.0b4
  • Firefox 93.0a1

Affected platforms

  • Ubuntu 20.04
  • macOS 12.0 beta
  • Windows 10

Steps to reproduce

  1. Launch Firefox
  2. Access this PDF Sample
  3. Scroll down to "Introduction" and zoom in on the blue icon

Expected result

  • The icon is rendered correctly in PDF

Actual result

  • The icon is rendered with scanlines

Regression range

  • Will see for a regression.

Additional notes

  • The issue can be seen in the attachment.
Has Regression Range: --- → no
Has STR: --- → yes

This issue does not appear to be a regression considering the fact that it occurs in Nightly as old as v85.0a1 and v65.0a1 or even v45.0a1.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0

I can confirm this bug. The Icons are set up by multiple images with 1px height.

This bug is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1164550

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.