Obey Keyboard Preferences tab key highlight setting in content area

RESOLVED DUPLICATE of bug 160387

Status

Camino Graveyard
Accessibility
--
enhancement
RESOLVED DUPLICATE of bug 160387
16 years ago
15 years ago

People

(Reporter: Michael Ulrich, Assigned: Brian Ryner (not reading))

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
The way how the tab key works can be set systemwide in 10.2. In the keyboard
preferences, under "Full Keyboard Access" there is an option "Highlight Text
boxes and lists only - Highlight any control".

When the first option is selected, the tab key highlights only few things
(similar to OS 9), while the latter option higlight everything (similar to Windows).

The way chimera works now is that it's always in "highlight everything" mode,
not yet taking the new system settings into account.

I suggest that the system options should be respected.

Comment 1

16 years ago
Michael, what build ID are you reporting this bug against?
(Reporter)

Comment 2

16 years ago
Build ID is 2002.09.30.04

Comment 3

16 years ago
To what extent do other OS X Apps observe this setting?

Comment 4

16 years ago
Reassigning to Accessibility.
Assignee: saari → bryner
Component: General → Accessibility
QA Contact: winnie → sairuh
(Reporter)

Comment 5

16 years ago
> To what extent do other OS X Apps observe this setting?

Preferences does it fully. Most other Apps are still adapting to it, because
it's a new thing in Jaguar (I think)

Comment 6

16 years ago
No, those options are available in 10.1.5, as well.
(Reporter)

Comment 7

16 years ago
Sorry, my mistake. I tried a few Apple apps to see how well this is 
implemented in them:

System setting is respected:
Finder 10.2, Mail 1.2, iPhoto 1.1.1, TextEdit 1.2, Terminal 1.3.1, 
Addressbook 3.0.1, OmniGraflle 2.0.8, iCal 1.0, Preview 2.0

Not respected:
iTunes 3.0.1, DVD Player 3.2, Quicktime Player 6.0.1, Acrobat Reader 
5.0.5

Comment 8

16 years ago
Confirmed using Chimera/2002100304 on 10.1.5, in that the setting doesn't apply
to the content area. The setting *does* apply to all Cocoa chrome areas, such as
the Toolbar and Preferences.

Obviously this doesn't work in Mozilla either.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Highlight links using tab key only when set in keyboard prefs → Obey Keyboard Preferences tab key highlight setting in content area

Comment 9

16 years ago
The problem here is that there isn't a good mapping into focussable things in
the content area. Should the 'All controls' setting focus links? See also bug
160387.
Target Milestone: --- → Camino0.8

Comment 10

15 years ago
*** Bug 203579 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
There is a patch I wrote that does almost what you want on bug 160387 - though
it doesn't follow system prefs. It adds a pref UI to Camino that allows the
users to choose tab behavior.
this should be resolved by 160387

*** This bug has been marked as a duplicate of 160387 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.