Closed Bug 1727027 Opened 2 months ago Closed 1 month ago

bug is not a valid parameter for the Bugzilla::Comment::create function.

Categories

(bugzilla.mozilla.org :: Bug Creation/Editing, task)

Production

Tracking

()

RESOLVED FIXED

People

(Reporter: wsmwk, Assigned: dkl)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

Steps:

  • starting with existing bug priority=P1 severity=S1
  • change status
  • clear severity to --
  • click save

Result:

  • priority had changed to --,
  • bugzilla internal error "bug is not a valid parameter for the Bugzilla::Comment::create function."

Thanks for the clear steps to reproduce Wayne :)

Poking at this in dev I get a different error using the same STR:

DBD::mysql::db do failed: Duplicate entry '14' for key 'PRIMARY' [for Statement "INSERT INTO longdescs (extra_data, type, edit_count, work_time, isprivate, bug_when, comment_id, already_wrapped, is_markdown, who, thetext, bug_id) VALUES (?,?,?,?,?,?,?,?,?,?,?,?)"] at /app/Bugzilla/DB.pm line 71.

via

File "/app/extensions/MozChangeField/lib/Post/ClearTrackingPriorityS1.pm", line 54, in "Bugzilla::Extension::MozChangeField::Post::ClearTrackingPriorityS1"

Commenting out the call to $bug->update() appears to fix the problem while although I'm not sure if there's any negative side effects of this. Note that ClearTrackingPriorityS1 isn't the only MozChangeField handler that directly calls $bug->update().

Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attached file GitHub Pull Request
Duplicate of this bug: 1728334

I see the PR was merged. Was it deployed?

I still see some problem when changing severity, the priority is reset even if I make an explicit choice. Should I file a new bug or is this still not deployed?

Flags: needinfo?(dkl)

(In reply to Marco Castelluccio [:marco] from comment #4)

I see the PR was merged. Was it deployed?

I still see some problem when changing severity, the priority is reset even if I make an explicit choice. Should I file a new bug or is this still not deployed?

This fix has been merged and deployed (I forgot to close the bug) on 20210901.1. So this bug should be fixed. For the above issue it sounds like a different issue and should be in a new bug please.

It may be that the extension code is making the change due to some other condition and will not allow it be explicitly changed to another value. We can discuss that in the new bug and also we are waiting to discuss changing the rules code once the original requester of the changes is back from leave.

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Flags: needinfo?(dkl)
Resolution: --- → FIXED
See Also: → 1732871
You need to log in before you can comment on or make changes to this bug.