Closed Bug 1727075 Opened 1 year ago Closed 11 months ago

Downloads panel elements not visible on hover with high contrast and system theme enabled

Categories

(Firefox :: Downloads Panel, defect, P3)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
94 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- verified
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- verified

People

(Reporter: Gabi, Assigned: pestanoa)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: access, regression)

Attachments

(2 files)

Attached image 2021-08-23_15h40_22.png

Affected versions

  • Fx 92.0b7
  • Fx 93.0a1

Affected platforms

  • Windows 10x64

Steps to reproduce

  1. Launch Firefox
  2. Enable system theme for about:addons
  3. Go to https://www.thinkbroadband.com/download and download some files
  4. Enable high contrast
  5. Open Download Panel and hover over Cancel download or Open containing folder

Expected result

  • Download Panel elements are properly displayed with high contrast and system theme

Actual result

  • Downloads panel elements not visible on hover with high contrast and system theme enabled

Regression range
Will search for a regression as soon as possible

Additional notes

  • See attached screenshot
Has Regression Range: --- → no
Has STR: --- → yes
QA Whiteboard: [qa-regression-triage]
Has Regression Range: no → yes
Regressed by: 1708690
Flags: needinfo?(dao+bmo)
No longer depends on: 1710926
Assignee: nobody → pestanoa
Status: NEW → ASSIGNED
Priority: -- → P3
QA Whiteboard: [qa-regression-triage] → [qa-regression-triage][access-s2]
Keywords: access
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebefb02bb4e6
Updated download folder icon to be visible on hover in HCM. r=mhowell,mtigley,desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Flags: qe-verify+

Reproduced the issue using an affected Nightly build from 2021-08-23.

The issue is verified as fixed on latest Beta 94.0b3, Win 10x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Please nominate this for ESR91 approval when you get a chance.

Flags: needinfo?(pestanoa)

Comment on attachment 9241705 [details]
Bug 1727075 - Updated download folder icon to be visible on hover in HCM. r=mhowell,mtigley

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: User facing bug, low risk fix
  • User impact if declined: Download icon will continue to not be visible when hovered on in HCM
  • Fix Landed on Version: 94.0b3
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only one line of change. Has been reviewed in nightly.
  • String or UUID changes made by this patch:
Flags: needinfo?(pestanoa)
Attachment #9241705 - Flags: approval-mozilla-esr91?

Comment on attachment 9241705 [details]
Bug 1727075 - Updated download folder icon to be visible on hover in HCM. r=mhowell,mtigley

Approved for 91.3esr.

Attachment #9241705 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
Flags: needinfo?(dao+bmo)

The issue is verified as fixed on 91.3.0esr, Win 10x64.

You need to log in before you can comment on or make changes to this bug.