Closed Bug 1727158 Opened 3 months ago Closed 3 months ago

Increase "dom.ipc.processCount.webIsolated" process limit per site to something greater than 1

Categories

(Core :: DOM: Content Processes, task, P2)

task

Tracking

()

RESOLVED FIXED
94 Branch
Fission Milestone MVP
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: cpeterson, Assigned: nika)

References

(Depends on 2 open bugs, Regressed 2 open bugs)

Details

(Keywords: perf-alert, Whiteboard: fission-soft-blocker)

Attachments

(2 files)

Based on the promising early results from our Nightly experiment comparing dom.ipc.processCount.webIsolated limit 1 vs 4 processes per site, we'd like to increase dom.ipc.processCount.webIsolated to something greater than 1. While we'd like to use a smart heuristic based on memory usage/etc when deciding whether to use a new content process, kmag thinks that can wait until after we ship Fission MVP and, in the meantime, we should just bump the limit before MVP.

Assigning to Nika because she will write related the related to patch to prefer existing content processes for new iframes (bug 1726865).

Deferring this bug from Fission Milestone M8 to MVP. This bug doesn't need to block our Release channel experiment (M8) and we wouldn't uplift a fix to Beta 92 this late in the beta cycle.

Fission Milestone: M8 → MVP
Depends on: 1727420
Depends on: 1728331
Depends on: 1728332
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b27aa06bb0f
Part 1: Fix tests which will fail when processCount.webIsolated is set to 4, r=annyG,extension-reviewers,rpl
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9888c5676034
Part 2: Bump processCount.webIsolated to 4 on desktop, r=annyG
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Depends on: 1730709
Flags: needinfo?(nika)

Part 2 got backed out, so needs to be re-opened

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Setting status-firefox93=wontfix because we don't want to uplift this change to Beta 93.

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55fa1d670b11
Part 2: Bump processCount.webIsolated to 4 on desktop, r=annyG
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Regressions: 1731604

(In reply to Pulsebot from comment #11)

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55fa1d670b11
Part 2: Bump processCount.webIsolated to 4 on desktop, r=annyG

== Change summary for alert #31407 (as of Tue, 21 Sep 2021 05:51:45 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
4% JS macosx1015-64-shippable-qr fission tp6 243,590,747.03 -> 233,171,387.11
3% JS macosx1015-64-shippable-qr fission tp6 243,068,148.10 -> 235,198,483.60

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=31407

(In reply to Pulsebot from comment #5)

Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9888c5676034
Part 2: Bump processCount.webIsolated to 4 on desktop, r=annyG

== Change summary for alert #31413 (as of Tue, 21 Sep 2021 08:14:53 GMT) ==

Improvements:

Ratio Test Platform Options Absolute values (old vs new)
3% JS windows10-64-2004-shippable-qr fission tp6 249,156,536.58 -> 242,193,647.62
2% JS windows10-64-2004-shippable-qr fission tp6 247,477,693.12 -> 242,102,502.06

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=31413

(In reply to Cristina Cozmuta (:CrissCozmuta) from comment #6)

Backed out for causing failures on image-loading-lazy-negative-margin.html
Backout link : https://hg.mozilla.org/integration/autoland/rev/1ef6dde7f1a04bc19d4a236716e41934b70597e2
Push with failures : https://treeherder.mozilla.org/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=9888c5676034836cd8a013d01565f10e78debb2d&selectedTaskRun=eQMd17K4SX-bkfwf6bDxaw.0
Link to failure log : https://treeherder.mozilla.org/logviewer?job_id=351486920&repo=autoland&lineNumber=9715

== Change summary for alert #31418 (as of Tue, 21 Sep 2021 10:40:51 GMT) ==

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
2% JS windows10-64-2004-shippable-qr fission tp6 242,251,999.39 -> 247,792,083.39
2% JS windows10-64-2004-shippable-qr fission tp6 241,080,598.72 -> 245,586,265.67

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=31418

Depends on: 1731792
Regressions: 1731792
You need to log in before you can comment on or make changes to this bug.