Closed Bug 1727175 Opened 5 months ago Closed 5 months ago

double clicking on attachment doesn't use its saved settings

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1690395

People

(Reporter: emoore, Unassigned)

Details

I'm using Thunderbird 91.0.2 under Windows 10 Home. If I click on a attachment such as Thunderbird_92_0b3.html in Rob Lemley's recent announcement of "Thunderbird 92.0b3 - build 1" I get a "Opening Thunderbird_92_0b3.html" popup pane that asks what should Thunderbird do with this file?

(*) Open with Vivaldi (default)
( ) Save file

[x] Do this automatically for files like this from now on.

If I double click on the same attachment using 78.13.0 (using the same profile) it does what I expect. It opens the html message in my systems default browser .

A similar problem occurs if I double click on the OpenPGP_0xF0B3DEEB56268743.asc key file. It displays a popup pane that displays

(*) Open with Browse ...
( ) Save file

[x] Do this automatically for files like this from now on.

despite tools -> preferences -> files & attachments showing "ASC file" (content type) should be used with "Use Vivaldi" (action).

In fact it occurs twice! because I get one popup to display it, I press OK, it displays the file in a Vivaldi tab, it displays the popup about it being a key file (that had been behind it), I close that popup and yet another popup occurs asking me how do I want to open the attachment (which is already displayed in a Vivaldi tab).

A side issue is what should occur if you see (*) Open with Browse ... and you click on OK. Is it supposed to default to using the systems default browser or is it supposed to popup the window for you to choose the helper applications? If the latter I'll file a separate bug report.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455

https://bugzilla.mozilla.org/show_bug.cgi?id=453455#c181 states "But the problem was just introduced in TB 91.0 for me. It has worked correctly for at least 10 years". Please explain why you don't want to treat this as a regression bug in version 91 since I'm not the only one who believes it worked for many years beforehand. It still works in my copy of version 60.9.1 and 78.13.0 for example.

The problem existed for a long time. It's just that changes to how we load messages to be multi-process compatible made the problem show the way it shows atm. So the symptom is new in 91, but the cause existed for a long time.

So, is it going to be fixed or not?

bug 1690395 has been reopened for tracking the Thunderbird fallout

Duplicate of bug: 1690395
You need to log in before you can comment on or make changes to this bug.