Closed Bug 1727304 Opened 10 months ago Closed 10 months ago

nntp setup should be moved out of "Other accounts"

Categories

(Thunderbird :: Account Manager, task)

Tracking

(thunderbird_esr91 wontfix)

RESOLVED FIXED
94 Branch
Tracking Status
thunderbird_esr91 --- wontfix

People

(Reporter: mkmelin, Assigned: henry)

References

Details

Attachments

(1 file)

New | Other Accounts... is now just NNTP. Also in the account manager.
We should have one entry for setting up an nnp account, and drop the other accounts entry.

Assignee: nobody → henry

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/3fc3104eb477
Transform old accounts wizard into a wizard for just newsgroups. r=mkmelin

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Duplicate of this bug: 1192096
   let identityPage = document.getElementById("identitypage");
   identityPage.addEventListener("pageshow", identityPageInit);
   identityPage.addEventListener("pageadvanced", identityPageUnload);
-  let incomingPage = document.getElementById("incomingpage");
-  incomingPage.addEventListener("pageshow", incomingPageInit);
-  incomingPage.addEventListener("pageadvanced", incomingPageUnload);
-  let outgoingPage = document.getElementById("outgoingpage");
-  outgoingPage.addEventListener("pageshow", outgoingPageInit);
-  outgoingPage.addEventListener("pageadvanced", outgoingPageUnload);
+  identityPage.next = "newsserver";
   let newsserverPage = document.getElementById("newsserver");
   newsserverPage.addEventListener("pageshow", incomingPageInit);
   newsserverPage.addEventListener("pageadvanced", incomingPageUnload);
+  newsserverPage.next = "accnamepage";
   let accnamePage = document.getElementById("accnamepage");
   accnamePage.addEventListener("pageshow", acctNamePageInit);
   accnamePage.addEventListener("pageadvanced", acctNamePageUnload);
+  accnamePage.next = "done";

Not sure why you set next on all of the pages; the wizard defaults to sequential which achieves what you need anyway.

You need to log in before you can comment on or make changes to this bug.