Closed Bug 1727336 Opened 2 years ago Closed 1 year ago

HTML buttons do not respond at muistachair.com with ETP set to STRICT

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1728594

People

(Reporter: raul.bucata, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image Screenshot_27.png

Environment:
Operating system: Mac OSX 10.15.6
Firefox version: :Firefox Nightly 93.0a1 (2021-08-24) (64-bit)

Preconditions:
ETP set to STRICT
Clean profile

Steps to reproduce:

  1. Navigate to : https://muistachair.com/
  2. Click on any button displayed on the page
  3. Observe the result

Expected Behavior:
A new page is opened

Actual Behavior:
The action returns no result

Notes:

  • Not reproducible with ETP set so STANDARD
  • Works as expected using Chrome
  • Screenshot attached
  • Reproducible on other desktop environments
Summary: HTML buttons do not respond at https://muistachair.com/ with ETP set to STRICT → HTML buttons do not respond at muistachair.com/ with ETP set to STRICT
Summary: HTML buttons do not respond at muistachair.com/ with ETP set to STRICT → HTML buttons do not respond at muistachair.com with ETP set to STRICT

Changing severity to S3 because this is TP issue in Strict mode.

Severity: -- → S3

Can reproduce with FF 92.0 and FF 94.0a1 (2021-09-10) (64-Bit) on Windows 10.

The problem does not appear when ublock origin is activated.

What I don't understand is when this happens and when it doesn't. For example why www.ra-micro.de is affected but www.voffice.pro isn't. Both pages have the same elements blocked by TP.

This is likely a dupe of bug 1728594, as that shims is being applied here and the buttons work for me now.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.