Closed Bug 1727668 Opened 1 year ago Closed 1 year ago

Integrate Merino with Firefox Suggest/quick suggest

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
3

Tracking

()

RESOLVED FIXED
93 Branch
Iteration:
93.2 - Aug 23 - Sep 5
Tracking Status
firefox92 --- fixed
firefox93 --- fixed

People

(Reporter: adw, Assigned: adw)

References

()

Details

Attachments

(2 files)

This integrates a fetch to Merino in UrlbarProviderQuickSuggest. We continue to
do the remote settings fetch too. Per the Jira ticket, we should prefer the
Merino suggestion when both sources return one.

Each fetch is controlled by a new pref and Nimbus variable, so we can enable
them independently.

At first I started making a UrlbarProviderMerino class, but it's better to
modify UrlbarProviderQuickSuggest because everything besides the fetch source is
the same: We want to collect the same telemetry, have the same results and
payloads, etc.

Blocks: 1727799
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4867cab4560e
Integrate Merino with Firefox Suggest/quick suggest. r=mak,nanj
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

qe-verify- because some urgent Firefox Suggest patches we want to uplift depend on this bug, but this bug is not related to the Firefox Suggest offline/online rollouts and does not need to be verified by QA for those rollouts. The feature added by this bug is also preffed off. Once it's enabled, we should have a round of QA for that feature (Merino integration) specifically.

Flags: qe-verify-
Flags: in-testsuite+

[Tracking Requested - why for this release]: Some urgent Firefox Suggest patches we want to uplift to a 92 dot release depend on this bug.

We're tracking the metabug for this work.

Approval Request Comment
[Feature/Bug causing the regression]: Firefox Suggest offline/online rollouts (this bug is not directly related but code that is directly related depends on it)
[User impact if declined]: Needed for important rollouts on 93 and 92
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No, low-level change with no visible changes
[List of other uplifts needed for the feature/fix]: See uplift coordination spreadsheet
[Is the change risky?]: Low risk relative to other uplifts needed in the patch stack
[Why is the change risky/not risky?]: This patch integrates a second source of data for Firefox Suggest (Merino) but it's preffed off. No visible changes.
[String changes made/needed]:

Attachment #9240786 - Flags: approval-mozilla-release?

Comment on attachment 9240786 [details] [diff] [review]
92/mozilla-release patch

Approved for 92.0.1.

Attachment #9240786 - Flags: approval-mozilla-release? → approval-mozilla-release+
Blocks: 1737137
You need to log in before you can comment on or make changes to this bug.