Closed Bug 1727772 Opened 1 year ago Closed 11 months ago

"There is no email program associated to perform the requested action"

Categories

(Thunderbird :: OS Integration, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1727230

People

(Reporter: bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: dupeme)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36 Edg/92.0.902.78

Steps to reproduce:

After upgrading from the 78.x series to the 91.x series, I'm getting the dreaded Windows 10 pop-up every time I launch Thunderbird:

"There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel."

I've uninstalled and reinstalled the product, and I've naturally set Thunderbird as the default application for e-mail in the Windows 10 "Default Apps" control panel (and also using Thunderbird's own "Use Thunderbird as the default client" within the "System Integration" UI). Problem occurs on two Windows 10 PCs (same OS version, same TB version and same TB profile under %AppData%).

The registry also seems like it's in order:

[HKEY_CURRENT_USER\SOFTWARE\Clients\Mail]
@="Mozilla Thunderbird"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
@="Mozilla Thunderbird"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
@="Mozilla Thunderbird"
"DLLPath"="C:\Program Files\Mozilla Thunderbird\mozMapi32_InUse.dll"

(followed by all the normal Thunderbird configuration you'd expect to appear at HKLM\SOFTARE\Clients\Mail\Mozilla Thunder)

Actual results:

The standard Windows 10 pop-up complaining that no e-mail program has been configured.

Expected results:

Thunderbird used to launch without complaint; getting this pop-up on every launch now asking me to set a default e-mail application.

Microsoft Windows [Version 10.0.19043.1165]

OS Name : Microsoft Windows 10 Pro
OS Version : 10.0.19043 N/A Build 19043

Keywords: dupeme
Blocks: tb91found
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1727230

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird]
@="Mozilla Thunderbird"
"DLLPath"="C:\Program Files\Mozilla Thunderbird\mozMapi32_InUse.dll"

I'm noticing you say : C:\Program Files
I would have expected C:\Program Files(x86)\

Is Thunderbird really installed in 'Program Files' or in 'Program Files (x86)' ?

Flags: needinfo?(bugzilla)

64-bit programs live in "C:\Program Files".

Flags: needinfo?(bugzilla)

64-bit programs live in "C:\Program Files".

Yes you would expect that, but it's not necessarilly the case. Hence why I asked you to check.
Have you always been using Thunderbird 64bit on that computer with default profile which has always and only been used on 64bit?

This profile has been migrated many times over many years; I've only used 64-bit Thunderbird on Windows for as long as the 64-bit build has been generally available from the usual download page (seems like a handful of years at this point?).

Documenting the fix here as well; simply remove these entries from prefs.js:

user_pref("ldap_2.servers.eds.description", "EDS Address Book Bootstrapper");
user_pref("ldap_2.servers.eds.dirType", 3);
user_pref("ldap_2.servers.eds.filename", "eds.mab");
user_pref("ldap_2.servers.eds.position", 1);
user_pref("ldap_2.servers.eds.uri", "moz-abedsdirectory://");
You need to log in before you can comment on or make changes to this bug.