Closed Bug 1727948 Opened 2 months ago Closed 2 months ago

Have separate opentabfor.middleclick for mailnews

Categories

(SeaMonkey :: Preferences, enhancement)

enhancement

Tracking

(seamonkey2.53? affected)

RESOLVED FIXED
seamonkey 2.90
Tracking Status
seamonkey2.53 ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.10)

Attachments

(1 file)

At the moment mailnews shares opentabfor.middleclick pref with the web links and users may not want different behaviour for web links versus messages / folders.
Adds Ctrl-Enter / Cmd-Return behaviour to folder and thread panes.
Whilst here let's expose opentabfor.doubleclick (which only has a meaning in mailnews) and correct the help for browser opentabfor.middleclick pref.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: less control of tab behaviour
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: changes to help and 7 new strings

Attachment #9238340 - Flags: review?(frgrahl)
Attachment #9238340 - Flags: approval-comm-release?
Attachment #9238340 - Flags: approval-comm-esr60?

Comment on attachment 9238340 [details] [diff] [review]
1727948-prefs-opentabformiddleclick-25310.patch

LGTM

Attachment #9238340 - Flags: review?(frgrahl)
Attachment #9238340 - Flags: review+
Attachment #9238340 - Flags: approval-comm-release?
Attachment #9238340 - Flags: approval-comm-release+
Attachment #9238340 - Flags: approval-comm-esr60?
Attachment #9238340 - Flags: approval-comm-esr60+
Blocks: 1729165

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/9a2e35d39e4f
Have separate opentabfor.middleclick for mailnews. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.10
Target Milestone: --- → seamonkey 2.90
You need to log in before you can comment on or make changes to this bug.