Closed Bug 1729235 Opened 1 year ago Closed 11 months ago

lightning read only caldav calendar losing RO setting upon start

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ verified, thunderbird93+ fixed)

VERIFIED FIXED
94 Branch
Tracking Status
thunderbird_esr91 + verified
thunderbird93 + fixed

People

(Reporter: je-vv, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Just start Thunderbird

Actual results:

You'll get after a little while several reminders you can't dismiss because they correspond to read only remote caldav calendar. You go and open the settings for that calendar, and you notice the "read only" setting is lost. You go and set it back to "read only", and now you can dismiss those old reminders. But if you close TB, and start it over again, once again the calendar comes with the "read only" setting lost, and you have to do the process all over again, every time starting TB.

Really annoying.

Expected results:

The remote caldav calendars should keep the settings provided by the user. Whether not read only, or read only, that setting should be kept as per the user configuration, and should be kept across TB turning off and turning back on...

Component: Untriaged → Provider: CalDAV
Product: Thunderbird → Calendar

Confirmed with Thunderbird 91.1.0 on macOS.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Same thing happens for me without a restart. You just have to enable a disabled read-only CalDAV calendar, which clears the read-only state.

Side note: There seem to be two instances (https://searchfox.org/comm-central/search?q=mReadOnly&path=calendar%2Fproviders%2Fcaldav%2FCalDavCalendar.jsm) where this.mReadOnly is used instead of this.readOnly as mReadOnly does not exist.

Duplicate of this bug: 1731246
Duplicate of this bug: 1731097

Ah, okay, this is a bug and I'm not going mad then! I'll look into it.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Keywords: regression
Regressed by: 1665203

Bug 1665203 set the read-only status to match the user's privileges on the server, but this clears a user-set read-only status if the user can write to the calendar but doesn't want to.

Also, gets rid of mReadOnly as it does nothing, and renames mDisabled to make it more obvious what it is.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c7904afdc4d3
Don't clear read-only status of CalDAV calendars even if it is writeable. r=mschroeder

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch
Duplicate of this bug: 1732119

Comment on attachment 9241993 [details]
Bug 1729235 - Don't clear read-only status of CalDAV calendars even if it is writeable. r=mschroeder

[Approval Request Comment]
Regression caused by (bug #): bug 1665203
User impact if declined: calendars stop being read-only when the user has set them to be
Testing completed (on c-c, etc.): landed yesterday
Risk to taking this patch (and alternatives if risky): low but non-zero chance of something weird happening

Attachment #9241993 - Flags: approval-comm-beta?

Comment on attachment 9241993 [details]
Bug 1729235 - Don't clear read-only status of CalDAV calendars even if it is writeable. r=mschroeder

[Triage Comment]
Approved for beta

Attachment #9241993 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9241993 [details]
Bug 1729235 - Don't clear read-only status of CalDAV calendars even if it is writeable. r=mschroeder

[Approval Request Comment]
Regression caused by (bug #): bug 1665203
User impact if declined: calendars stop being read-only when the user has set them to be
Testing completed (on c-c, etc.): in 93.0b5
Risk to taking this patch (and alternatives if risky): low but non-zero chance of something weird happening, no reports so far

Attachment #9241993 - Flags: approval-comm-esr91?

Comment on attachment 9241993 [details]
Bug 1729235 - Don't clear read-only status of CalDAV calendars even if it is writeable. r=mschroeder

[Triage Comment]
Approved for esr91

Attachment #9241993 - Flags: approval-comm-esr91? → approval-comm-esr91+
Duplicate of this bug: 1736262

Verified when testing the 91.2.1 release candidate on Windows 10.

Status: RESOLVED → VERIFIED
Regressions: 1738443
No longer regressions: 1738443
You need to log in before you can comment on or make changes to this bug.