forward inline of Base-64-encoded (Big5) message body is incorrect

RESOLVED DUPLICATE of bug 307023

Status

MailNews Core
Composition
--
major
RESOLVED DUPLICATE of bug 307023
16 years ago
9 years ago

People

(Reporter: Yeh You-Ying, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-TW; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-TW; rv:1.1) Gecko/20020826

Some html style message can not be forwarded as inline.
Please refer to the attachment.

Reproducible: Always

Steps to Reproduce:
Just forward(inline) a message as the one of the attachment and then you will see.


Actual Results:  
Should be correctly displayed in message window.
(Reporter)

Comment 1

16 years ago
Created attachment 101957 [details]
the original message source

This attachment is the source of message which can reproduce the issue.
(Reporter)

Comment 2

16 years ago
Created attachment 101958 [details]
The outlook of message source 

The orignal message looks as the attachment.
(Reporter)

Comment 3

16 years ago
Created attachment 101959 [details]
The message source of the forwarded message (inline).
(Reporter)

Comment 4

16 years ago
Created attachment 101960 [details]
The issue looks as the attachment.

All contents are codes not words...:(
(Reporter)

Comment 5

16 years ago
This issue occures in 1.0 / 1.1 / 1.2a.
Are you generating the message the same way you did for bug 151732? Just curios
to know if there is a relation between those two bugs.
Naoki, do you mind taking care of this bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
okay, reassign to nhotta, qa contact to marina
Assignee: ducarroz → nhotta
QA Contact: esther → marina
(Reporter)

Comment 9

16 years ago
>>------- Additional Comment #6 From Jean-Francois Ducarroz  2002-10-08 15:31
-------
>>Are you generating the message the same way you did for bug 151732? Just curios
>>to know if there is a relation between those two bugs.

Yes, the message is generated same as the way of bug151732. :)
Product: MailNews → Core

Comment 10

13 years ago
Problem appears to be related to the body being encoded as Base-64.  
See the attachment 169181 [details] (bug 196180) which exhibits a similar problem for a 
quoted-printable message body; also the problem message in attachment 110665 [details] 
(bug 137022) is Base-64 encoded.


Still extant in trunk (TB 1.0+0506).
Summary: content of forward inline is all strang codes. → forward inline of Base-64-encoded (Big5) message body is incorrect

Comment 11

13 years ago
*** Bug 305377 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
xref bug 307023.

Comment 13

10 years ago
Reconfirmed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1pre) Gecko/2008062602 SeaMonkey/2.0a1pre, almost identical result when forwarding
this message inline. Resetting assignee and QA per bug-day instruction.

This may be a special case of bug 296282, showing similar (but shorter)
arbitrary strings when forwarding base64-encoded text/html with images in multipart/related structure, also with encodings other than Big5.
Assignee: nhottanscp → nobody
QA Contact: marina → composition
Hardware: PC → All
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 14

9 years ago
I believe this bug has been fixed, probably by the patch to bug 307023.

Comment 15

9 years ago
thx, marking dupe.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307023
You need to log in before you can comment on or make changes to this bug.