Closed Bug 1730226 Opened 11 months ago Closed 5 months ago

Adding lots of attachments can cause the window to overflow

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird_esr91+ wontfix)

RESOLVED FIXED
100 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird_esr91 + wontfix

People

(Reporter: henry, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fixed by bug 1720348])

Steps to reproduce

  1. Open composition.
  2. Make sure the window is relatively small.
  3. Add lots of attachments.

Result

If the attachment area becomes larger than the available vertical space, the window's content height will become cropped at the bottom. This means that the status bar disappears, and later attachments cannot be seen.

The user can fix this by using the splitter between the attachment area and the message editor to lower the height of the attachment (it might take a few steps). Note, that this solution would not be available to a keyboard user.

Or they could increase the window size, but this is usually limited by the screen height. Or they can collapse the attachment pane, but once it opens they will have the same problem and they cannot see the last attachments.

Expect

We stop the attachment area growing beyond the available space in the window.

Origin

This happens because we set the height of the attachment area directly when we add attachments.

https://searchfox.org/comm-central/rev/15a241fd84b92b74caf0b75d70ffed980b3397d1/mail/components/compose/content/MsgComposeCommands.js#6553

Version: unspecified → Thunderbird 91
Blocks: tb91found

Good find.
I think this is happening due to 2 factors clashing with each other:

  1. As you correctly pointed out, this happens because we set the height of the attachment area directly when we add attachments.
  2. The other factor is the forced limit we apply to the resize of the attachment area, which can't grow past 2/3 of the full height of compose window, in order to prevent collapsing entirely the body area. So, when the attachment area is forced to grow when we set the height value, it can't grow up and it pushes the rest of the content down.

Indeed, some smarter checks to manage the height of that container should be in place.

Depends on: 1720348

Fixed in bug 1720348

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1720348]
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.